External battery charger for Librem5

How long did it take?

1 Like

Not long indeed, perhaps less than four/five minutes. Thanks for asking! I knew right away that I forgot to measure time (you’ll do this I guess, please). I flipped with Alt Tab to check (actually write/prepare my post) something else and flashing process happened already. I didn’t even erased my previous installation of PureOS on Librem 5 eMMC.

I’ve tried 3 total cables (2 USB-A to USB-C and 1 USB-C to USB-C)

I’ve 2 batteries, I make sure at least one is always fully charged.

This vibrates twice and green LED but nothing afterwards, I’ve tried it.

Without battery phone alternates between green LED and amber LED

I’ve been using PureOS on my Laptop. Also I’ve run sudo apt install build-dep ./ this gets all required packages

This only adds udev rules and I’ve done it as first step, can’t run uuu without root if I don’t add udev rules

I’ve definitely kept it running for hrs.
Adding battery images


I am curious why you not reaching the eMMC with Jumpdrive, if your eMMC it corrupted you will not be able to flash the L5 with the flasher, so i recommend you get a SD card with GNU OS(Pure OS) to booting the L5 then reformating the eMMC, then you will be able to flash your GNU Device again.
@joao.azevedo we waiting for you to get an operating system on sd card to booting on L5 to formating an eMMC corrupted.

Not reaching eMMC is my assumption.
Behavior is: waiting for usb.
I’ll wait for a day for support to respond (it’s weekend)

1 Like

Yes, as I recall this is happening (not working) with the original Librem 5 power supply, but I managed to power on Librem 5 with another PD 5.0V/3A (it delivers 5.0V only) power supply without any issues. Anyway, you are not getting enough initial power there to get to the point of Success 1 (I’m finally following yourself) and this is your main problem (perhaps not even related to eMMC, you are not even getting close to there, I’m now aware of that fact, since recently), just my brief guess. Will be back to reread your post soon, need to leave now … microSD card will not help there either …

1 Like

Maybe you have multi issues like usb-c port broken too. : ( many fake/cheap usb-c cables it may broken the usb-c port or the bad use of usb-c cable to phone too.
@librem5 do you get charging the battery of L5?

Might be that we are having belonging diagnosis (as in this moment cannot find in my head another/proper technical term) there. I mean knowledgeable Purism people can pinpoint (point out, I hope) now where the actual problem lies, which hardware (or software) location might be damaged, if so.

Therefore another question from my side: is it this steady (constant) green LED light constantly there, is it staying there forever? So long until Librem 5 battery removed. Perhaps another brief press on power button again might change something toward positive move, move ahead, perhaps Librem 5 boots again. Please repeat this procedure by swapping your batteries as well, focus yourself only on that for a while (although your previous PureOS already erased (if so) and neither installed there completely again). Get somehow this Success 1 output/message please.

 Green | The U-Boot bootloader has started running. 

@librem5, please read about within this link. Green (flashing) is explained further below: includes advice.

This thread has evolved into a wall of text that, from a quick glance, contains a lot of wild guesses and incorrect assumptions.

@librem5 it appears that your device gets stuck at some point while trying to boot from USB (which is a prerequisite for both flashing and launching Jumpdrive). This can either mean issues with USB communication (on either host or device side) or outright broken hardware that can’t even successfully boot into the bootloader. Please contact support.


:joy: finally dos it here.

1 Like

Yes already discussing it with support.
Expecting reply tomorrow or so about further steps.

1 Like

Got the RMA, I’ll update the post once I get phone back.

1 Like

I own an additional battery, an universal charger and I charged it with this external charger (specs are visible below). The battery shows now 4.303V. As I read in this and other threads:

  1. I should not insert the battery with this voltage. correct?
  2. What should a resistor has as Ohm (Ω) to discharge the battery externally before inserting?

UPDATE: IIRC my electronic school, a battery of 4500mAh and 4V which will be discharged in 9h means that this is done with: 4500mAh / 9h = 500mA = 0.5A and following R = U / I means: 4V / 0.5A = 8Ω. A I wrong?


1 Like

Post can’t be empty

1 Like

You can insert it, just keep the modem and GPS off until it goes below 4.2V (POWER_SUPPLY_VOLTAGE_OCV).


Just received my phone with motherboard replacement :crossed_fingers: .
I’ll update the thread by next week (or earlier if I hit issue).

1 Like

I can enter jumpdrive, I don’t have need to flash right now so not trying flash at moment.

1 Like

Trying to bring things back on topic, I have been looking for one of those charging stations like the ones for recharging sets of 2-way radios to charge up 2-4 spare Librem5 batteries at once. My reason is that I still want to figure out a way to stop bringing android/ios with me when I go on backpacking trips. Plus, I think just having a small pouch like those USB drive carrying cases with a few extra batteries in it would be easier and less bulky than an external battery pack.


4 spare batteries would be 16000 mah + kinda big charging station, I think at that point one or 2 10000 mah external packs would be more convenient and lighter.


I’ve been carrying both pretty much wherever I go for the last six months: one spare L5 battery and one 20,000 mAh power bank.

I almost always end up using the latter. Not having to power down the phone and then boot up again is just too convenient.

In two scenarios, I still find the spare battery useful: when traveling light, e.g. at concerts, and at venues where bringing power banks is forbidden, e.g. at the stadium.

1 Like