External battery charger for Librem5

@librem5, several questions (even if you already answered or already gave other hints about them please bear with me) if you don’t mind:

Did you tried already some other USB-A to USB-C cables (just borrow few from your neighbors, up to 0.6m are preferable, should work ones but any will do if just the right one, right choice for the purpose)?

Did you already charged your Librem 5 battery externally up to the point where all four green LCD indicators are staying/lighting steady (when charging stopped at 100%=4.2V)? Asking while suppose that your L5 battery might have some issues, not balanced well or whatever (but not dead one) and suppose you are not having second one to make sure that the your only Librem 5 battery can deliver over 2.0A (even over 2.5A) right from the start of boot procedure. That your battery depletes significantly is already clear but please repeat restart of your phone (directly or through Jumpdrive or any other method) only with over 75% of your battery capacity (your external universal charger will show capacity of it without … see attached picture). Note that steady Librem 5 red LED light will be steady even when L5 battery at 0% of its capacity (we know that but please bear with me). If you live within Europe I might send you another L5 battery overnight, just ask for such help if needed.

Furthermore when your phone’s battery at almost 100% did you hold power button for over 16 seconds and tried to get it back to life that way (I don’t recommend using original power supply when doing this, holding prolonged switch-on button, while not sure …)? As kindly, with emphasis on important procedure, described and explained here:

You are an advanced Linux user and very flexible one (know very well how to find your way through Linux environment) but keeping our dialog alive will help all of us here in this Forum. Did you already tried to power your Librem 5 from its original power supply (it is rated as PD 5V/3A) from, without Librem 5 battery inserted? I never tried this by myself as cannot trust that this will stay within 5V range in any situation and never ever negotiate higher number than 5.0V, but that’s just me.

Please download this PureOS amd64 image (18-Mar-2022 one), burn it on some quality USB Flash drive and use it on/with your laptop in order to repeat needed steps to get your Librem 5 work again. Even installing newest uuu (if needed to be added/installed, probably) package within this live setup is just normal procedure (we do not need to keep there anything forever), although for temporary usage only. If any add-on package necessary:


Just my two cents with hope that any of above (in particular or as combo) questionings or tips help for real.

Related to JumpDrive procedure:


# ./scripts/librem5-flash-image --udev
2022-03-20 15:34:12,246 INFO Udev rules '/etc/udev/rules.d/70-librem5-flash-image.rules' already present

Related to UUU:

$ uuu -udev

@librem5, please execute as advised within the bottom of output (check if output is the same):

1: put above udev run into /etc/udev/rules.d/70-uuu.rules
	sudo sh -c "uuu -udev >> /etc/udev/rules.d/70-uuu.rules"
2: update udev rule
	sudo udevadm control --reload

I’ve put every HKS off (mandatory), on Librem 5 Linux smartphone of course!
@librem5, when ready once again to re-flash your Librem 5 (without using JumpDrive), as initially described in my post #48 above, please remove microSD card if inserted (not just important, this step might be mandatory, but not sure).
I’ve disconnected my laptop from the Internet as well:

/Downloads/Flash_Librem5# uuu -lsusb
uuu (Universal Update Utility) for nxp imx chips -- lib1.4.193
/Downloads/Flash_Librem5# uuu -dry flash_librem5r4.lst
uuu (Universal Update Utility) for nxp imx chips -- lib1.4.193

Note that I didn’t get Success 1 (was Success 0) right away, yet it finally displayed at the end of this flash, as posted here, but orange LED light on my Librem 5 was showing me that librem5r4.img is transferring to it smoothly.

/Downloads/Flash_Librem5# uuu flash_librem5r4.lst
uuu (Universal Update Utility) for nxp imx chips -- lib1.4.193

Success 1    Failure 0                                                                                  
2:1      3/ 3 [=================100%=================] SDPV: jump                                        
3:1      4/ 4 [Done                                  ] FB: Done 

After I removed USB-A cable end from my laptop there was green LED light on my Librem 5. Decided to press power on button and hold it. Few seconds afterwards it was out. Another short press (less then 2 seconds) powered on my Librem 5 with brand new PureOS, as correctly installed, and 123456 passwd (unknown to me :grinning:). Thank you Purism so much! Yesterday (or one evening before) I was only reading about how to (official instructions) and today my “homework” already done.

How long did it take?

1 Like

Not long indeed, perhaps less than four/five minutes. Thanks for asking! I knew right away that I forgot to measure time (you’ll do this I guess, please). I flipped with Alt Tab to check (actually write/prepare my post) something else and flashing process happened already. I didn’t even erased my previous installation of PureOS on Librem 5 eMMC.

I’ve tried 3 total cables (2 USB-A to USB-C and 1 USB-C to USB-C)

I’ve 2 batteries, I make sure at least one is always fully charged.

This vibrates twice and green LED but nothing afterwards, I’ve tried it.

Without battery phone alternates between green LED and amber LED

I’ve been using PureOS on my Laptop. Also I’ve run sudo apt install build-dep ./ this gets all required packages

This only adds udev rules and I’ve done it as first step, can’t run uuu without root if I don’t add udev rules

I’ve definitely kept it running for hrs.
Adding battery images


I am curious why you not reaching the eMMC with Jumpdrive, if your eMMC it corrupted you will not be able to flash the L5 with the flasher, so i recommend you get a SD card with GNU OS(Pure OS) to booting the L5 then reformating the eMMC, then you will be able to flash your GNU Device again.
@joao.azevedo we waiting for you to get an operating system on sd card to booting on L5 to formating an eMMC corrupted.

Not reaching eMMC is my assumption.
Behavior is: waiting for usb.
I’ll wait for a day for support to respond (it’s weekend)

1 Like

Yes, as I recall this is happening (not working) with the original Librem 5 power supply, but I managed to power on Librem 5 with another PD 5.0V/3A (it delivers 5.0V only) power supply without any issues. Anyway, you are not getting enough initial power there to get to the point of Success 1 (I’m finally following yourself) and this is your main problem (perhaps not even related to eMMC, you are not even getting close to there, I’m now aware of that fact, since recently), just my brief guess. Will be back to reread your post soon, need to leave now … microSD card will not help there either …

1 Like

Maybe you have multi issues like usb-c port broken too. : ( many fake/cheap usb-c cables it may broken the usb-c port or the bad use of usb-c cable to phone too.
@librem5 do you get charging the battery of L5?

Might be that we are having belonging diagnosis (as in this moment cannot find in my head another/proper technical term) there. I mean knowledgeable Purism people can pinpoint (point out, I hope) now where the actual problem lies, which hardware (or software) location might be damaged, if so.

Therefore another question from my side: is it this steady (constant) green LED light constantly there, is it staying there forever? So long until Librem 5 battery removed. Perhaps another brief press on power button again might change something toward positive move, move ahead, perhaps Librem 5 boots again. Please repeat this procedure by swapping your batteries as well, focus yourself only on that for a while (although your previous PureOS already erased (if so) and neither installed there completely again). Get somehow this Success 1 output/message please.

 Green | The U-Boot bootloader has started running. 

@librem5, please read about within this link. Green (flashing) is explained further below: includes advice.

This thread has evolved into a wall of text that, from a quick glance, contains a lot of wild guesses and incorrect assumptions.

@librem5 it appears that your device gets stuck at some point while trying to boot from USB (which is a prerequisite for both flashing and launching Jumpdrive). This can either mean issues with USB communication (on either host or device side) or outright broken hardware that can’t even successfully boot into the bootloader. Please contact support.


:joy: finally dos it here.

1 Like

Yes already discussing it with support.
Expecting reply tomorrow or so about further steps.

1 Like

Got the RMA, I’ll update the post once I get phone back.

1 Like

I own an additional battery, an universal charger and I charged it with this external charger (specs are visible below). The battery shows now 4.303V. As I read in this and other threads:

  1. I should not insert the battery with this voltage. correct?
  2. What should a resistor has as Ohm (Ω) to discharge the battery externally before inserting?

UPDATE: IIRC my electronic school, a battery of 4500mAh and 4V which will be discharged in 9h means that this is done with: 4500mAh / 9h = 500mA = 0.5A and following R = U / I means: 4V / 0.5A = 8Ω. A I wrong?


1 Like

Post can’t be empty

1 Like

You can insert it, just keep the modem and GPS off until it goes below 4.2V (POWER_SUPPLY_VOLTAGE_OCV).


Just received my phone with motherboard replacement :crossed_fingers: .
I’ll update the thread by next week (or earlier if I hit issue).

1 Like

I can enter jumpdrive, I don’t have need to flash right now so not trying flash at moment.

1 Like