External Microphone on Librem 5

It seems in byzantium on my librem5 the built in mic works fairly well without any tweaking, but I have been unable to get any external microphone from any headset (3.5 mm or bluetooth) to actually show as a option to select / use test. Do other people have external mic’s working? I noticed after reflashing once my list of mic’s at least looked changeable where it did not even appear to allow a change before, but even after I hook up bluetooth headsets I still get no option for additional microphones…

I don’t have a L5 and this is a shot in the dark, but for Bluetooth did you change the headset type to headset? I’ve had to do that before elsewhere.

yes there are two audio profiles in the headset and neither type allows a mic to show up… also the same bluetooth devices worked fine on my librem 13)

A working headset mic is being worked on and an initial version should be available in the next few updates of the package librem5-base, so in a few weeks AFIK


@joao.azevedo so does that fix have impack on both 3.5 mm and bluetooth ? (so I know to stop tweaking with it and wait LOL)

Only 3.5mm jack.


I think this may be a known longstanding limitation with the Bluetooth profile support.

A fun option might be a USB audio dongle (preferably one with TRRS support) i.e. if you can’t wait for mic support in the connector at the top of the phone.

1 Like

I tried it today, and the mic of my external headset (3.5 mm jack) works fine, except it needs to be manually selected (in contrast to the output device part).

Interestingly, after manual selecting and then unplugging, the settings correctly switch back to the internal mic :slight_smile:

FYI we got automatic detection to work just a few days ago, so it should arrive with updates in a not very far future :wink:


Still the external mic only appears in the preferences, but still without being auto-selected as it should.

Additionally, a few times I saw the settings app freezing when I tried to open the input drop down, even to the degree that the app couldn’t be closed (popped back when I tried to close it).

Still the external mic only appears in the preferences, but still without being auto-selected as it should.

That’s right, the patch that implements automatic detection didn’t make it into any release yet. It got blocked because it was coupled with some other audio changes which turned out to be hard to deploy without potentially breaking existing configurations. I still have to split the problematic changes out, so the rest can go in now while the problematic part will likely have to wait for the next PureOS release.