Failed to boot into OS after a fine successful install

Hi. After a fine successful installation of PureOS 9 on my Ideapad, I can’t boot into the OS. Everything was fine during installation. GUI, WiFi, and Touchpad worked great. I even surfed some web pages using PureBrowser but after installation was done and I rebooted, I get two errors (after decrypting the hard drive).

The progress bar and PureOS logo are also perfectly shown but there’s these two errors which prevent me to use the OS.

amdgpu requires firmware installed

rtl8821ae: Polling FW fail!! REG_MCUFWDL: 0x00000306

I don’t think graphic processor has any problem as when I was installing and testing PureOS it had no error no problem. Everything was fine and as I said even the PureOS boot logo and decrypting progress bar are fine.

What should I do? Can I fix it?

These are the errors I get when I boot and when I do dmesg (live):

https://upload.disroot.org/r/bG4ccr0_#h02D96enxaOlmkPq+jwyGFOOQaO+eBgHvtqps4954DY=

https://upload.disroot.org/r/HsCbnVUZ#sIwPpWKBmCXD0WzA6rdfDIeStvUSisHhvL4buKctPNE=

https://upload.disroot.org/r/qQG1Tokd#xkQ9bwpce9LYq938TjklYu7f1LSZRc6MqeSNgnTrSaI=

https://upload.disroot.org/r/FsoMYWda#kP8zMJrPKUMdjUWcGutoRPffDwGp+AFABIaj+7IVe+g=

https://upload.disroot.org/r/E4QKJfXT#eGfM9O5bDB7FYU4d1+qaudrjx2eQ8d1fBr6U2hV7hSM=

https://upload.disroot.org/r/PEV2DZbg#XVmGh/8SR1yI3uHSsXkX/JzuC6YbmbKLoclyk8p82ZA=

AMDGPU is an open source kernel driver but requires proprietary firmware to function. PureOS does not include proprietary drivers or firmware for AMD CPUs or GPUs.

This appears to be coming from the WiFi.

Is the WiFi working after install and boot?
Was the WiFi working before install?

Is there an ethernet port on this laptop? The reason I ask is that if there is then you need to be sure that surfing web pages is being done via WiFi e.g. ensure that ethernet port is not connected in order to answer these questions.

rtl8821ae requires proprietary firmware to work. Probably the reason for this error.

https://packages.debian.org/buster/firmware-realtek

I think the issue is that he claimed that everything worked fine:

So, the question is: Does the OS boot from the install iso have the rtl8821ae driver? If it doesn’t then why did the Wifi work during the installation process???

The mystery is why “Everything was fine during installation. GUI, WiFi, and Touchpad worked great.” Specifically, the Wifi should not have worked.

One way to tell is to boot the installer as if you were installing. Instead of proceeding with the installation you can use the “Window key” and start “tilix” (a terminal). From there you can “lsmod” and grep for rtl to see if the Realtek driver is loaded. You can also “sudo dmesg” to see the logs and test whether Wifi was working (because it should not have been).

So how does it work when I’m booting the live disk and installing it?

I can’t boot to user space but during installation and testing the distro it works fine. I even surfed some webpages during the installation progress.

Yes. If rtl8821ae driver is not included, then how does Wi-Fi work during installation progress? How I booted the live disk and opened PureBrowser? Same for amdgpu.

Well it was working. I surfed some webpages with PureBrowser. Everything worked perfect when I booted to live disk.

What I was saying was that you could find out by booting from the live disk again and inspecting the log for the boot, the various modules loaded, as well as which firmware is loaded.

Those pictures in my original post are from dmesg on live disk.

Hmm. Puzzle: From that logfile, I would say that wifi wasn’t working … but you claim to have working network. So, while you are on the live iso I would investigate where the network access is coming from:

  1. Did you have an ethernet adapter (or a second wifi adapter) plugged in?

  2. Try “ip addr show” (to list the ip addresses). Also try “sudo lshw -class network” or “sudo lshw -class network -short”

  3. Try lsmod | grep rtl

  4. If you have rtl8821ae listed in lsmod, try “modinfo -F firmware rtl8821ae”. If you have some other “rtl” module (rtl = Realtek), try a modinfo on that.

There’s no adaptor for internet except for built-in Wi-Fi adaptor. This message is being written using PureOS live disk connected to Wi-Fi.

These are the output for network adaptors:

H/W path                     Device      Class          Description
===================================================================
/0/100/2.3/0                 wlp1s0      network        RTL8821AE 802.11ac PCIe 
/0/100/2.4/0                 enp2s0      network        RTL8101/2/6E PCI Express

These are outputs for rtl:

rtlwifi                98304  3 rtl_pci,rtl8821ae,btcoexist
mac80211              815104  3 rtl_pci,rtl8821ae,rtlwifi
cfg80211              761856  2 rtlwifi,mac80211
libphy                 77824  3 r8169,realtek

Thanks!

  1. What did “ip addr show” give? I’m asking because that’s what will show whether wlp1s0 (wireless) or enp2s0 (ethernet) had the active address.

  2. Also: I’m not sure if PureOS uses NetworkManager, but the command “nmcli” will also give information. Try typing “nmcli”. [nmcli is a bit better because it will provide the name of the operate kernel module. ]

  3. I’m not familiar with rtlwifi and libphy modules. It’s possible that whatever wifi card you have allows some sort of limited functionality (e.g. no “ac”) without the proprietary firmware??? I’m just not familiar. Commands like “modinfo -F firmware rtlwifi”, “modinfo -F firmware libphy”, “modinfo rtlwifi”, “modinfo libphy” might give more info.

1 & 2 are more important.

I’m not interested in PureOS anymore. I just give up. It’s not just Wi-Fi. Nothing shows up after install so I believe it’s not worth digging into it.

It’s working live so it should work installed too. If it doesn’t then it doesn’t. I’m done working on it.

Thanks a lot for your time. I really appreciate it.

No problem. I agree by the way. I don’t use PureOS. I don’t even use Debian anymore. I just saw your post on reddit and found the problem interesting/strange.

sounds like https://manjaro.org/ < is your friend :slight_smile: