Failed to parse appstream.xml.gz error when running flatpak search

Environment: PureOS 10 (Byzantium)
flatpak version 1.10.8

Full error:
: Failed to parse /var/lib/flatpak/appstream/flathub/x86_64/active/appstream.xml.gz file: Error on line 85714 char 136: <li> already set 'Protection against a common misconfiguration that tends to break apps, the ' and tried to replace with ' development variable'

The search operation actually seems to work but the error is annoying.

Looks like this is most likely an outdated flatpak dependency problem.

Tried adding the flatpak stable ppa to update to the latest version as suggested in this comment but got stopped cold during apt upgrade operation with the error:

Error: The repository 'http://ppa.launchpad.net/flatpak/stable/ubuntu noble Release' does not have a Release file.

I tried running flatpak repair too but that did not resolve.

1 Like

That is because noble is for the Ubuntu codename.

do you know of a workaround?

1 Like

@irvinewade

Wait around until Irvine or another user familiar with Ubuntu can provide instructions for you.

Looks like those instructions are for Ubuntu, not PureOS though. So may or may not work.

Worse still, they appear to be for the Ubuntu release, noble numbat, which is not even released until next month(!) (unless there are unexpected delays, in which case later). So that makes the instructions even sketchier.

Mixing repositories is in any case always a bit risky.

I don’t know the best way forward but maybe see whether there is a repo for an earlier release of Ubuntu i.e. step back through mantic, lunar, kinetic, and finally jammy.

1 Like

Do you think it’s possible to implement a fix now that Ubuntu Noble Numbat is out?

Seems that the PureOS version of flatpak is somewhat dated at any rate. Are there any plans for updating the versions of apps like the flatpak cli utility on PureOS?

1 Like

@irvinewade

Probably not on Byzantium, but Crimson has more updated packages.