Faulty Live USB image? live file system missing?


#1

I’m trying to see what PureOs is all about but so far after ~8 hours didn’t even boot properly from USB image.
I’ve tried 3 differed USB sticks with 3 Programs(Etcher, Rufus, Unetbootin) on 2 different desktops
On my main machine(Ryzen 3600 on b450) it seems to have problem with NVMe2 SSD
on my work deskdop(old core 2 DELL) it trhows for 2-3 minutes:

FAT-fs (sdb1): IO charset ascii not found
mount: mounting /dev/sdb1 no /cdrom failed: Invalid argument
stdin: not a typewriter
stdin: not a typewriter

and finally

(initramfs) Unable to find medium containing a live file system

Debian, ubuntu , mint, linuxcnc are running fine with any combination of usb sticks/software/PC.
Downloaded iso image sha256 is correct.
Any suggestions?
I might try burning it to dvd, if i find any dvd’s and my burner still works after 4 years of dust collection duty


#2

Which image are you using?
Which BIOS do you have on your machine?

Here’s the latest live image: https://pureos.net/download/
(Hit the “Download .iso”) button to download the image.


#3

Bios on ryzen?
7A38vM8 agesa 1.0.03ab, it’s beta ryzen3000 could explain nvme2 access problem, but problem exists only with pureos.
Old core 2 q8600 dell OPTIPLEX 760 has unknown bios.
Downloaded only version I can see, PureOs8.0. From the same page you linked.

BTW I’m going away for rest of September so I’ll be qiet for a bit.


#4

The other distros may include non-free software to boot from UEFI. PureOS is a FSF approved Free Software distro so we don’t include non-free code.


#5

Both bioses boot non uefi. Uefi in 2003? Seriously?
On both machines pure is trying and failing to mount every single partition from all hard drives.
AFAIK it’s far past potential UEFI problem


#6

Yeah, the roots of EFI date back to the '90s and Intel stopped developing theirs in 2005 to contribute to the UEFI Spec.


#7

ls /sys/firmware/ can tell you if you have EFI firmware on the machine.


#8

Booted gparted live in legacy mode

ls /sys/firmware
acpi devicetree dmi memmap

Booted linuxcnc(Debian wheezy)

ls /sys/firmware
acpi memmap

NO EFI/UEFI
Both sticks boot only in legacy mode, ryzen bios gives me a choice. PureOs stick boots in legacy mode too.

BTW, never seen uefi bios on consumer motherboard before 2007-ish
anyway my optiplex is 2009(i could have sworn it’s older) BUT 100% non uefi bios.