Firefox-esr on the Librem 5

I tried the suggestion from @JR-Fi about the firefox mobile config which helped make things more like the mobile version on my android phone but, alas, still can’t see the logon box. :thinking:

I’ve resorted to digging into the web developer console on my laptop to inspect all the elements for clues. (think falling down the rabbit hole)…

1 Like

Did you already try the default gnome browser and making the bank/login page a web app? Can that see the text boxes? How about screen size (not FF zoom size - but try that too)?

Yes to your first question. Their site rejects it and displays a message saying “We no longer support this brower” and “Please see our list of supported browsers here” at a link.

It’s definitely not a scaling issue, the boxes are roughly the same width and size as the “Signin” button. However the web-fu they use to build that part of the page just is not getting rendered by this browser. My next step is to try some less desirable browser but, I may turn to Anbox and the android app the bank puts out before doing that as a last resort. I also emailed support because the Librem 5 brochure site clearly shows this bank’s logo as an app on the section of the page where they discuss “native apps” giving the impression that it’s been done and worked for someone at some point. I really hope they didn’t just assume it would and grab bunches of app logo’s for that page… :man_facepalming:

I found that using Chromium gets around that problem for some sites:
sudo apt install chromium
You can also try changing Firefox’s user agent, so the site thinks that you are using mobile Chrome.

I think I’ve narrowed down the problem… Maybe. I got past the user agent string issue but, the login box appears to be some fancy use of CSS to present the input boxes for username and password which isn’t getting rendered by the browser. So, I get a “Sign In” button with no place above it to enter the credentials.


The new Mobile Settings (phosh-mobile-settings) app has one setting to help with browser window size. Maybe some help?

I’ve noticed that the FF is not rendering everything right. Not sure why. I use NoScript extension and the small selection window that comes under the menubar icon is/stays so small, that there is no way to conveniently select anything. Rotation makes no difference. Only a small chance that these are related, but still.

Yes, I suspect that the CSS that adjusts FF for a mobile screen doesn’t take every extension into account. I’ve found sometimes I need to switch to another window, then switch back to FF and then I can tap Noscript icon and see settings. Other times I need to long tap it to open the full noscript window.


Also in terms of viewing sites that don’t have responsive web design, I’ve found in addition to the config that our firefox-esr comes with on the Librem 5, that adding the Mobile View Switcher plugin really helps. When toggled on, it presents a mobile browser user agent to sites, which helps with sites that don’t adapt simply based on screen size, but based on user agent instead. It also removes a lot of the bloat which makes web browsing more enjoyable, as many sites remove a lot of their extra ads and other bloat when they see a mobile user agent. To the point that I would even suggest folks try the plugin on desktop computers.


Odd thing is it loads just fine in chromium…

Not surprising, web developers these days always test at least against Chrome and if it doesn’t work there it’s considered a bug. Any browser beyond that who knows. That said, if the site is reading your user agent and deciding it isn’t supported based on Firefox version, you may try updating your Librem 5 as a recent firefox-esr package did just show up late last week for security fixes.

Already did that. And yes the devs at chase are probably not testing on ff esr but, it works fine on my windows laptop with the regular version of ff too. I’m just mostly annoyed that I can’t seem to pinpoint the library that’s missing or whatever.

I’ll figure out how to get some screenshots to help show the issue later.

But is it the same or similar version of FF as on the Librem 5? PureOS upstreams the firefox-esr package from Debian stable, and it tends to be a number of versions behind the latest-and-greatest version you might be using on Windows.

First with chromium, then with FF

I would install the Mobile View Switcher in FF, enable it, and then see what page it presents, although it looks like the window is sized off of the screen there too, as though the firefox-esr-mobile-config package isn’t actually installed.

I had tried that before too but, for the sake of this conversation I just did again. Same result.

In the screenshot, the plugin is installed, but currently disabled. Touch that mobile view switcher icon and it will turn from grey to orange/yellow.

Hmm I’m out of ideas then. You can at least tell the Mobile View Switcher is working because you see that “open in the chase mobile app” prompt at the top, but it’s clear something with this website and this version of Firefox is causing the web app to hide the login part.

On my laptop with Debian and FF the username/password field can take several seconds to load. As the phone is less powerful, have you tried waiting a minute or three to see if it eventually loads? Also I vaguely recall one of the privacy settings breaking this (though it may have been a plug in as well, it’s been a while since I had the prompt not load at all).

Yup. Like I said, it’s gotta be some underlying library version or something specific to JavaScript and / or CSS that works on the latest FF version on my laptop but is missing on our PureOS or FF-ESR package.

I appreciate your attention though Mr. Rankin. I wish the epiphany browser were more stable so I didn’t need FireFox or another but, here we are.

1 Like