Firmware and USB Issues


#1

I am using a Librem 13v2 (updated software/coreboot 4.7), and am running into the below firmware issues. Any advice on how to solve them would be appreciated.

$ sudo dmesg | grep firmware
[ 0.030427] Spectre V2 : Enabling Restricted Speculation for firmware calls
[ 1.602017] i915 0000:00:02.0: firmware: failed to load i915/skl_dmc_ver1_26.bin (-2)
[ 1.602023] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[ 1.602028] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_26.bin failed with error -2
[ 1.602030] i915 0000:00:02.0: Failed to load DMC firmware i915/skl_dmc_ver1_26.bin. Disabling runtime power management.
[ 1.602031] i915 0000:00:02.0: DMC firmware homepage: https://01.org/linuxgraphics/downloads/firmware
[ 2.861949] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x361f00)
[ 14.922353] platform regulatory.0: firmware: failed to load regulatory.db (-2)
[ 14.922357] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[ 14.984525] usb 1-3: firmware: failed to load ar3k/AthrBT_0x11020100.dfu (-2)
[ 14.984530] usb 1-3: Direct firmware load for ar3k/AthrBT_0x11020100.dfu failed with error -2


#2

Yes, I get many of those messages as well.

[ 2.533984] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x361f00)
[ 46.829579] platform regulatory.0: firmware: failed to load regulatory.db (-2)
[ 46.829583] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[ 46.829586] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[ 46.958798] usb 1-3: firmware: failed to load ar3k/AthrBT_0x11020100.dfu (-2)
[ 46.958803] usb 1-3: Direct firmware load for ar3k/AthrBT_0x11020100.dfu failed with error -2
[ 4150.832719] usb 1-3: firmware: failed to load ar3k/AthrBT_0x11020100.dfu (-2)
[ 4150.832739] usb 1-3: Direct firmware load for ar3k/AthrBT_0x11020100.dfu failed with error -2


#3

I get these error messages as well, any reason why?


#4

Because there is no firmware to load. You can safely ignore these warnings, as the hardware work normally without firmware.


#5

For my USB on the left side of the laptop, using an Libre 13v2 w/Coreboot 4.8.1 now, it is still unresponsive. It just stopped working one day (even before the Coreboot update), and I can no longer use the port for anything.


#6

You need to contact us then, as it might be a hardware issue.


#7