First calls with the L5

I got the SIM for my L5 from my provider, an O2 outlet here in Germany. Internet works fine with 4G. But when I do a phone call and put the L5 to my ear this menu of the upper part opens and closes all the time. How this could be avoided?

To add: And the called people do not here me :frowning:

3 Likes

I haven’t gotten my L5 yet, so this is an ignorant take, but in some models of Android, it can be helpful to push the power button to darken the screen during the call. Then the screen will only light up and respond to touches when the power button is pressed again. Seems plausible that the L5 would work this way too? Or at least it should be possible to make it work that way through custom configuration.

1 Like

I checked it with two devices in my hands: the L5 does not record any audio.

Never had this problem. Maybe, try to put the phone not too close to your ear?

Fix for additional line, I had the same problem until I realized I had the killswitch for Camera & Microphone ON! So turn it off :smiley:

2 Likes

Thanks. Enabling the mic with its kill switched solved the problem. Sometimes I’m stupid. Sorry for the noise with the mic problem.

1 Like

I checked it with my Ubuntu mobile BQ E4.5: during a call when I put something near the upper part, my hand or whatever, the display gets switched off to not disturb the call.

Does the L5 have not such sensor there?

Yes, it’s called a “proximity sensor”, there is some info about it here: https://developer.puri.sm/Librem5/Development_Environment/Phone/Troubleshooting/Testing_Proximity.html

It is used to make the screen go black when holding the phone close to the ear (or close to anything else) during a call, at least it works like that on Byzantium.

2 Likes

Don’t know how it is handled so far but a strong visual feedback in case of no microphone found (=killswitch on) would be pretty nice.

It is visible in the upper status line where all the stati of network etc. are shown, that the mic and cam are disabled. But, not in the dialer app as a “strong visual feedback”. This seems to me a valid change request, for example adding to the message line:

The call is not encrypted.
The call is with micro switched to OFF

or something like that.

3 Likes

I’ll have to enable this and give it a shot!

Afaik, in byzantium it shows the mic off status in the top status line. Also, I think the proximity sensor behavior was improved in byzantium. Which PureOS version do you have running?

None so far, ordered mid 2019, just interested in the topic. :slight_smile:

Yes it does, but if you concentrate on the dial pad or the contacts you can miss it, as I did. A clear message on the screen in the call would be better.

Re/ the sensor: it switches off the screen when you are 1cm away (you can test it with your hand while in a call). This seems to be late or it depends on the position of the sensor relatively to your head/ear.

purism@pureos:~$ uname -a
Linux pureos 5.13.0-1-librem5 #1 SMP PREEMPT Thu Oct 7 02:47:51 PDT 2021 aarch64 GNU/Linux

can you do:

cat /etc/lsb-release to check the OS version?

I also used O2 in Germany. When you say the other persons cannot hear you, you mean no sound at all, or echo?

$ cat /etc/lsb-release
DISTRIB_ID=PureOS
DISTRIB_RELEASE=10
DISTRIB_CODENAME=byzantium
DISTRIB_DESCRIPTION="PureOS 10"

There was no audio at all on the remote end because I called with the micro switched off. My fault!

Happened to me as well :smiley:
Takes a bit of time to get used to the idea that a phone as a microphone kill switch and that that is something that you need to consider :stuck_out_tongue: