Flare -Signal problem

Hi, I have installed Flare- Signal for my Librem5 and have used it all of yesterday to receive, send multiples messages to people, send attachements to myself and more. Was working great the first day, i had notifications working perfectly. Today I can still receive messages and notifications, however whenever i try to answer i get an error message. I took a screenshot of the error message on my Librem5 and posted it here for you to see: https://imgur.com/a/DX1TJoM

I’m sure there is a fix for this as it was working yesterday perfectly (1st day with my librem5) but I’m a total noob who is used to an iPhone. Any help appreciated thanks

You send too many messages so the system think you are a (ro)bot. And this is why it try to force you to solve a recaptcha. And now you should file a bug for that App you are using (Flare-Signal?) to implement that recaptcha Code.

You could not solve it, because that issue was not implemented in your viewing Client.

Recaptcha is something that Humans try to implement into manual wrote code, to have some tests to mostly humans to secure its not a Computer Program… however. A Computer Program would understand that, reverse engineer that client software, patch it and compile it again to solve that kind of issue, while humans ask other humans for help… its so sad these days after A.I. set Humans chess mate in the Past.

For you, i think if your account did not got banned, you just can write less often Messages. :slight_smile: And it will work after some time again.

1 Like

interesting, so i heavy signal user like me couldnt realistically use this app? i have maybe 20 signal contacts which many of them i interact all the time.

Should i just rest the app for a few hours? days?

I am not sure how Signal or the Signal Web Client, try to detect spam-Bots. So i think just a few seconds would help… or one Message every Minute. But i am just guessing.

I assume you do not use some community proxy or other VPNs like the Tor network, to drop that messages. It can be an issue that we try to use a Desktop-App with a Desktop Browser on a Phone without Mouse and Keyboard, and the Webclient try to collect that Data to solve that recaptcha issue.

Edit: Or if you are at home, try to use a Mouse and Keyboard and connect your Librem5 with a Docking Station to a Power Supply and a lager Screen. Sometimes its about moving Mices and open other Tabs or playing Music and browse the Internet in parallel like human do, too. /Edit.

Often its like Spam-Mail-Filtering and you do not know the Arguments to pass the filter or to filter every spam mail.

Personally i would try to use gpg Mail or some XMPP-OMEMO encrypted alternatives, with close friends or family, for heavily daily use. But i know this is not a good solution if you have not time to set it up, or the patience with the social links in our fast living world.

Simulating human interaction won’t work. Signal does not collect any kind of that data on the clients. This would not make any sense because it’s easy to circumvent. They are checking IPs server-wise and ask for captchas when specific IP(-blocks) were used for sending spam or reported for sending spam.
Typically this message appears while using VPN providers.

Funny enough I use a VPN all the time on all my devices except on my Librem5 which I haven’t had time to setup yet lol. My VPN is mullvad and i usually tunnel to either Miami, USA or Toronto, CAN. I am in Mexico

Could also be that your provider uses IP ranges from which spam was reported in the past.

will try to setup mullvad today and see where it takes me lol

Installed Mullvad easily, verified it was on by checking IP, openned Flare, try to send a message and nothing, no error but the message doesnt get send either

It could be possible that Signal wants a new captcha verification. You can get a new token from https://signalcaptchas.org/registration/generate.html but I don’t know what the command would be to add it /give it to Flare (or any other Signal app).

1 Like

Account blocking would be set up on account / phone number level so a spammer could not just change the ip address to unblock the account.

Reload a new flare and fire again?


I tried that yesterday without success but today it seems to be working for now.


does anyone have flare working?

I’ve tried but failed. I don’t get passed the libsecret error. Then I have also tried to use Axolotl, it starts, but I never get the text message verification code.

1 Like