Flashing to Byzantium

I had the same problem on Ubuntu - and hence wrote: https://source.puri.sm/Librem5/community-wiki/-/wikis/Building-uuu-and-Jumpdrive

It worked for me and, given the similarity with Mint, maybe will work for you.

1 Like

considering that uuu https://tracker.debian.org/pkg/mfgtools is in debian testing I find it strange that it is not in ubuntu and derivatives.

Seems that the package exists in ubuntu since Ubuntu 21.04:

https://packages.ubuntu.com/impish/uuu

https://packages.ubuntu.com/source/impish/mfgtools

EDIT: latest Linux Mint seems to be based on Ubuntu 20.04 so that is why it does not show in the repos.

2 Likes

Yes, exactly. You will note in my build instructions that it says for “Ubuntu 20.04” (focal). Ubuntu then went and wasted my time because as of 21.04 (hirsute) the package uuu is there. https://packages.ubuntu.com/search?keywords=uuu However I would have needed to build Jumpdrive anyway.

1 Like

you might get away with rebuilding the deb package from source on 20.04 and some minor tweaks in the control file, like lowering the debhelper version.

But the operative term here is: might

Still waiting for Byzantium to be officially released for L5 by purism. Will this ever happen? Some people have written that this is around the corner, but it seems that this corner is a long turn…

2 Likes

Byzantium is kind of on two tracks: laptops and phones. It might not offocially be released in general, but it’s the recommended OS for the phones now.

OK, but I haven’t seen an easy way to switch. If it is the recommended shouldn’t exist a trivial way to upgrade? All I read is several scripts and flashing and honestly I am confused. Has Purism setup a webpage saying “this is recommended and this is how you do it”?

I read for example the link https://developer.puri.sm/Librem5/Development_Environment/Phone/Troubleshooting/Reflashing_the_Phone.html
Look the section for flashing. It is so difficult and mainly uncertain. Where is the choice of Byzantium on this page? Maybe I do not have the correct link though.

I was expecting a news article from Purism saying “do that”. I either missed it or never existed.

5 Likes

There is no choice on that page, the flashing defaults to Byzantium. I think that’s kind of became official when we switched the flashing scripts to stop using Amber unless requested.

I’m not sure why we haven’t made this official though, but I will raise the topic internally.

2 Likes

Oh well. We can skip this step an install the python dependencies we need on our own. @dcz listed them above. (or in https://source.puri.sm/Librem5/librem5-flash-image/-/blob/main/requirements.txt)

I’m unsure if those packages are available independently in linux mint repos. I think you could install sudo apt install python3-pip then do something like pip3 install -r requirements.txt. If that works or you manually install the deps then you can continue on with the instructions.

1 Like

Thanks. I’m a little scared to try this now; I don’t want to break my L5. :laughing:

With that post topic title, I can’t get this out of my head… thanks, middle school English Lit! :roll_eyes:

I absolutely know that feeling. I’ve flashed it twice now and I feel it each time. For what it’s worth I think you’ll be fine. The python script basically downloads/verifies the image your need, uboot, and sets up a uuu script, and waits for you to plug in. The very last thing it does is call uuu with the script. uuu is the actual thing writing to your device. If you are missing any of the python deps it will error out and tell you something like import x failed. Figure out what you are missing, install it. This can be repeated basically forever. If you make it to it telling you to plug in I’m pretty sure you’re golden.

1 Like

I took me a heart and flashed my librem5 using

https://developer.puri.sm/Librem5/Development_Environment/Phone/Troubleshooting/Reflashing_the_Phone.html#download-the-flashing-scripts

and it worked!

The only shortcoming until now is, that the camera is not working.

1 Like

If you have time, try rebooting a few times and check if the camera works sometimes or if it never works. I think there have been some problems that have seemed random, something with how the kernel initializes things at boot time. Not sure if all that is fixed yet.

There was an easy solution: Gain was nearly 0, so I did not see the picture.

2 Likes

You frightened me there.

Apparently newer versions of megapixels have some autofocus changes. I’m excited for them because manually I can’t seem to take a halfway decent photo. Still love seeing the progress.

1 Like

Upstream Megapixels is not shipped with the Librem 5. In fact, we just renamed our branch to Millipixels, so that people can have both in the future. I’m not sure if the upstream Megapixels works at the moment though.

EDIT: actually, I’m sure it doesn’t work, it’s not compatible with our driver. The drivers will change in some weeks at least.

2 Likes

I just received my L5 the other day…but out of the box mine has byzantium installed by default.

1 Like