Flatpak: no remote refs found similar to 'flathub'

I am trying to use flatpak and whenever I try and install anything I get this error stating:

error: No remote refs found similar to ‘flathub’

I have googled this error and it seems that this occurs when flatpak does not know about this repo. This common solution seems to be to run the following:

flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

To add the repo however after doing this I am still seeing the same issue.

When I run flatpak remotes I get the following:

flatpak remotes    
Name    Options    
flathub system

I think this means that the repo is known to flatpak. Finally if I run:

flatpak remote-add flathub https://flathub.org/repo/flathub.flatpakrepo

I get an error stating:

Error: Remote flathub already exists

I have tried uninstalling flatpak using sudo apt remove flatpak then sudo apt purge flatpak and reinstalling with sudo apt install flatpak however the problem still persists.

Does anyone know how to go about rectifying this?

The packages I want to install are:

What are you using to install those flatpaks?

I haven’t been able to install them yet but I wanted to use flatpak.

How are you trying to install them? Are you using the flatpak command, i.e.

flatpak install org.gnome.Podcasts

or are you using a graphical interface?

I am using the flatpak command. The following command is throwing this error:

flatpak install --user flathub org.freedesktop.Sdk.Extension.rust-stable//21.08

This command is what is in the installation instructions on the gitlab page.

However this works (I only just figured out that this works):

flatpak install flathub com.belmoussaoui.Authenticator

I just ran this command again but dropping the --user and it is working now.

flatpak install flathub org.freedesktop.Sdk.Extension.rust-stable//21.08

Seems this was mostly me being an idiot. Anyway if anyone runs into this problem in the future you now have an answer.

If you want to have user-level installs from Flathub instead of system-level, you can run

flatpak remote-add --user --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

Then you should see an additional user option listed for flathub in the output of flatpak remotes.

$ flatpak remotes
Name          Options
flathub       user

Then you can use the --user flag with your installs as you were trying before, and it should work

I added the Flathub repository by following the instructions at:


After adding the repository I’m able to find the flatpaks I want throught the Software app.

Looking at my PureOS Store settings I see that support for Flatpak is installed. Under Software Repositories I see Flathub dl.flathub.org and three applications installed - System installations. The slider is on but greyed out.

I tried running that repo file on the PureOS help section of the Flatpak site and my L5 refuses to run it.

The one app I know was installed as a Flatpak, Cozy, does not appear as installed in the PureOS store.

The email that got sent out about 8 Things to Do After Unboxing says I ought to see Flatpak items in PureOS store to install at this point but I don’t.

What am I missing?