Geoclue2 insists on 3g although disabled

Today I tried to use maps and it still shows me at some other place, the headquarters of the mobile provider (I am with mobile data on).

I checked /etc/geoclue/geoclue.conf
and I have


How can I force only gps location? When I connect to network through usb-c geoclue changes its mind about my location. If I disable the usb-c network it changes again its mind to what it gets from the modem. But 3g is disabled in geoclue.conf How come it pops up all the time? What does it mean “enable=false”. Is this a bug of geoclue?

There is already a thread to discuss same thing,.
Some evergreen it has the antenna loose to the main frame, if so, the Librem 5 will never get GNSS working not matter what geoclue config it has or Hw Rv.

Are you refering to this Librem 5 GPS/Location Tracking

You see the problem is not that gnss is not working. If I turn off Mobile Data and Wifi, then the
where-am-i command returns the correct position. Just double checked.

But when Mobile Data is on (or wifi) it changes its mind and returns wrong position. And of course Maps does not work offline. So I am stuck.

This is the problem and it does not relate to the antenna:

It remains “Open” two years now. Is there any way to bypass this problem and force the gnss position?

Maybe try, as per the issue that you link, “Workaround was to set the url to nonsense”.

However that issue appears to be discussing WiFi v. GNSS chip - rather than “3G”.