Getting system lock ups with Pure Browser


#1

Hi there. I’ve been having a couple issues with my machine ever since the latest update of PureOS. I think I’ve tracked down the most painful, but I don’t even know where to begin with this one. After watching Youtube for a while on PureBrowser, it will lock up, and I won’t be able to click anything. Closing Pure Browser by clicking the ‘x’ in the top right seems to only exacerbate things, as I can’t use my keyboard, and mouse clicks no longer register (though the mouse does still move). I end up having to hard reboot my system.

Today there was an interesting instance of this that might illuminate the problem to the more Linux savvy: I set a video to full-screen, and I got the little notification that it was full screen, but the video was still the same size, and I could still see the YouTube interface. I hit ESC, and tried doing it again, but now my mouse clicks no longer registered, and my pointer was acting like whole page was clickable, though nothing was happening. I closed PureBrowser, but the audio from the video was still playing. Fortunately, my keyboard was still responding, so I typed inps into Tilix, but it just hung. From that point, my keyboard was unresponsive. I clicked the top right menu on the screen to tell the computer to restart, and I got a warning that 3 PureBrowser processes were running, one of which being unresponsive. I hit cancel to see if I could figure out a way to force quit it, but as soon as I hit the Super button to bring up my applications, the whole system became unresponsive and I hate to hard reboot.

Any thoughts on this?