Gigabit ethernet not working on Librem mini v2

I cannot have 1000Mb/s on ethernet on my Librem Mini v2 from 2021.
Tried everything from different forums.

  • Different cables work on another computer.
  • Changing ethernet port does not solve.
  • With ethtool forcing 1000Mbps it stops the connection ("no cable found), then back to 100, it finds the cable.
  • In dmesg i see:

r8169 0000:02:00.0: firmware: failed to load rtl_nic/rtl8168e-3.fw (-2)
[ 15.422897] r8169 0000:02:00.0: Direct firmware load for rtl_nic/rtl8168e-3.fw failed with error -2
[ 15.422901] r8169 0000:02:00.0: Unable to load firmware rtl_nic/rtl8168e-3.fw (-2)
[ 15.423421] RTL8211E Gigabit Ethernet r8169-0-200:00: attached PHY driver [RTL8211E Gigabit Ethernet] (mii_bus:phy_addr=r8169-0-200:00, irq=IGNORE)
[ 15.502264] r8169 0000:02:00.0 eno0: Link is Down
[…]
[ 29.840954] r8169 0000:02:00.0 eno0: Link is Up - 100Mbps/Full - flow control rx/tx
[ 29.840976] IPv6: ADDRCONF(NETDEV_CHANGE): eno0: link becomes ready

Please help ! Does it really need a prop. firmware for that???

Can you clarify … are you saying that you are certain that it used to work at gigabit speed and now it doesn’t? Or are you saying that you are certain that it never worked at gigabit speed? Or something else?

Does “changing ethernet port” mean … you plugged the Mini into a different port on a switch? router? what? make/model? (The reason for asking this is that many such devices have LEDs on the front that tell you at a glance whether a single port is bogusly negotiating 100 Mbit/sec or conversely that all ports are negotiating 100 Mbit/sec. If it’s a managed switch then you can even go in and look at the link from the switch’s perspective.)

It’s probably worth having a quick look at the RJ-45 connector (socket) at each end to make sure that the pins look normal.

Sorry to be unclear.
It is the first time I connect it to a gigabit connection. Yes, I tried other ports of my brand new router (Free Delta S) to which my Librem 14 connects with gigabits at all ports of the router with the same cable.
LEDS :

  • Librem 14 : none / router orange + orange
  • Librem mini ( PureOS and EC and bios are up-to-date) : orange + green / router blank + green. If I force the gigabit connection with ethtools, the connection is lost and LEDs blank.
    A hardware issue?

Your fault isolation seems solid. Did you have a look at the RJ-45 socket on the Mini?

You might need confirmation from someone who has a Mini that GbE normally works.

I wouldn’t assume a hardware issue just yet.

What do you mean with the “look at the socket”? I just looked at it from outside. It is stable, has 8 metal pins. Should I open the mini? What is to look for? Fortunately i have another mini at my office and will test it on the router at home.

Yes, just from the outside.

Tested with my other mini : it works. So my first mini has a problem. I received the mini at the same time last summer.
Should i contact the support ?

Yes. support@puri.sm

1 Like