Gnome not working after upgrade to Byzantium

I decided it would be a good point to upgrade my Librem15rev3, since I was hoping that a newer glibc would solve some problems when installing some software that I need for work.

So I changed from “amber” to “byzantium” in /etc/apt/sources.list, did

sudo apt update
sudo apt upgrade --without-new-pkgs

which seemed to have worked. Then I tried

sudo apt full-upgrade

and I got the message

The following packages have unmet dependencies: libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6 is to be installed

(like in this post: Upgrade to Byzantium). I was not able to fix this by deinstallng gcc or libc6-dev.

I did a reboot never the less, and now I can not log in to my computer anymore - I get a login window, but upon entering the password, either I am thrown back to the login screen or I get a (occasionally flickering) greyish screen with the mouse pointer. So it seems gdm3 is still broken with byzantium?

I managed to login in “failsafe mode”, but I can’t get the WiFi card connection to work, so the PureOS repositories are not reachable.

I did not expect the upgrade to behave that bad. I read some posts about problems with byzantium, but these were partly 2 years old.

Not sure how to proceed. I’d rather not wipe the system (or should I?).

Don’t suppose you have a USB ethernet dongle? Or for that matter a USB WiFi dongle? (In either case, it would be a temporary measure so that the repo is accessible. However that in itself isn’t useful unless you know what to install, deinstall or reinstall - and I can’t help you with that.)

I do have an USB Ethernet Dongle, but at the moment no cable (or ethernet port on the wall) to connect.
I’ll keep trying.

OK, I got a cable and could connect the laptop to the internet in recovery mode. Then I followed the suggestions at (mentioned here Upgrade to Byzantium) and I got past the libc6-dev message.

Patiently ploughing through the list of upgradeable packages using various iterations of apt install ..., apt update, apt upgrade, I arrived to the login screen and could login. System seems to be working, but new desktop apps need to get used to still.

However, the screen is flickering, last time I had this, I could cure it with an update of the firmware. Does anyone know if this is still the recommended way to go?

1 Like