GNOME Web jumps to maximum audio volume

since PureBrowser was removed recently I thought I give GNOME Web another try. Then I remembered what made me prefer PureBrowser/Firefox over Web in the first place. Whenever I play sound within Web, be it a video, music or whatever, sound output jumps to 100% and blasts my brain out. I couldn’t find any information on this problem. Any help? I really like Web and would like to make it my #1 browser.

1 Like

I have this issue with Gnome web on Debian Buster as well so I don’t believe it’s a PureOS only issue. I’ve not dug into it too deeply because I don’t use gnome web often…

Sorry I don’t have a solution but, you’re not alone.

I have similar problem with a gnome shell plugin (online radio), each time I play another station, sound level jumps to 100%. So this is perhaps issue deeper in the GNOME somewhere.

Yes this is a more general issue, not specific to PureOS

1 Like

Okay thanks. Well it’s a pity, since I’ve been having this issue for months if not years and it makes Web unusable for me. Anyway, I opened a bug report. Hopefully it can be solved some day.

Edit: This workaround fixed it for me.


I reported this awhile ago.

I doesn’t happen on Phosh with flat volumes set to enabled (last time I checked).

1 Like

niceguy, thanks for solution, I’ll see with our devs if we could include this by default.


not exactly the solution you’re looking for but … i always prefer to HAVE an external something that i can manually rotate a knob for the volume … an AMP/DAC is what usually does the trick … doesn’t have to be expensive just to have the knob


Depends on the use case.

For desktop the user may well have external speakers that have a volume control knob.

For laptop the user may be using the internal speakers and no volume control knob.

Some keyboards, whether laptop or external, have dedicated keys or key sequences to quickly adjust the volume.

Anyway, the user has found an appropriate workaround.

1 Like