Has anyone gotten Wire or Tutantota to work on Byzantium?

I’ve been told AppImages will not work on the Librem if they’re for x86 architecture, so that explains why Tutanota’s and Wire’s appimage won’t work for me.

Oddly the flatpak on the Flathub site for Tutanota will not work because it is out of date. (So why is it still there?)

Wire and Tutanota have web sites to access the mail, but they won’t work on the Librem either, because both Wire and Tutanota say the Librem browser is not acceptable to them.

Are there other options I’m not aware of that do work?

Flathub issue: You’ll have to ask them.

By the way, have you added the Flathub repo to the L5 yet? Did you search for, find, and attempt to install Tutanota and Wire from the store app? (I haven’t tried, myself, as I don’t have accounts with them.)

Browser: Did you install Firefox-ESR yet? I imagine it would be “acceptable” to Wire and Tutanota.

Yes, I have flathub repo added, I have successfully installed other flatpaks.

I don’t find Tutantota or Wire in the Purism software store.

After I had posted my question I learned about the Firefox-ESR browser. I installed that, and yes, it does work (barely) for these two sites. Layout for Wire is very poor on the Librem 5.

1 Like

If you try to run the AppImage from the terminal, are there any errors? For a long time, the --no-sandbox option was needed (Source) but I don’t think it’s necessary anymore. Also make sure the AppImage has executable permissions (chmod +x tutanota-desktop-linux.AppImage) since downloading the application from https://tutanota.com/#download doesn’t appear to have it.

The Flathub version hasn’t been updated due to some issues that need fixing.

Yes, I did try running the appimage from the terminal, I did get errors, don’t recall now what they were though.

On the Librem 5 the only AppImages that work for me are those that specifically state they are designed to work on the arm64 architecture - which makes sense. My impression is that the vast majority of AppImages are not designed to work on an arm64 device. My guess is that’s the problem with the Tutanota AppImage file that I downloaded from their site.

When I search from the store app, I find Tutanota flatpak, but not Wire. I installed Tutanota, and the initial screen looks like it fits. It did throw an error the first time I tried to launch the app, but not the second time.

I don’t have an account, and I’m having trouble trying to create one (maybe due to all my various browsers’ privacy settings).

I already had a Tutanota account. When I installed the Tutanota flatpak file, it installed, but when I log in I get a message from Tutanota saying they will no longer allow people to use that flatpak because it runs an out of date version of Tutanota.

1 Like