Headphones do not work

Hi, my external speakers work fine. When I insert the headphones into the jack, nothing happens - the audio remains on the external speakers. thanks

Select it manually the audio sink, or update the EC and Coreboot to last.

thanks. I’m rather new here so I don’t know how to perform that. I did check in the Settings under Output device but there are no option to select headphones. I have Librem 14

1 Like

What is the Operating System?

Linux Live5D 5.10.0-21-amd64 #1 SMP Debian 5.10.162-1 (2023-01-21) x86_64 GNU/Linux

1 Like

Same thing happens on my old Dell Latitude with linux Mint. I have to go to the volume icon on the lower right, go to sound settings and manually switch to the USB PnP sound device (headphones).

I never thought switching should be automatic. Unless I pull the plug and it needs to find another device to output with.

You can update the EC firmware and coreboot using these instructions:

EC: https://puri.sm/projects/librem-ec/
coreboot: https://source.puri.sm/firmware/utility/#usage

1 Like

I updated the EC firmware and I still can’t get the headphones to work :frowning:

Did you update coreboot as well? Both are needed for this fix

I followed the steps as per https://source.puri.sm/firmware/utility/#usage

I chose all the defaults.
Rebooted. Still no sound from headphones

Good, those are the instructions for coreboot. So you did the EC update (booted the EC update ISO and ran flash.sh) and also ran the firmware utility above?

Can you manually select headphones in settings? If so, then it’s still using the old verbs, which would happen if either coreboot or the EC firmware wasn’t updated. If not, then it’s using the new verbs, but the jack detect implementation isn’t working.

Yes, I ran the flash_ec.sh and the the EC update.

I don’t see headphones in the settings

There was some other thread where the user tried stereo headphones (or was it a mic?) and it didn’t work.

Perhaps get a stereo to mono adapter jack?