Help needed with 21:9 and Librem 15 v3. (HDMI 1.4, HDMI 2.0, ultrawide)

I’m trying to get my Librem 15 v.3 to display 21:9, will this HDMI to DP adapter make it work?

It only goes to 30Hz, but my understanding is this is the only option I have. If I’m honest, i don’t even understand how it makes any difference… the graphics must have limited resources to attribute to different outputs?.. :thinking: Maybe someone can explain how an adapter can even have an effect on internal graphics capability to me. (thanks!) :grinning:

– More details below for starting a discussion or for later reference to aid others –

My specs:

Graphics: Intel HD Graphics 520 [Skylake GT2]
Display: Asus PG348Q - 21:9 at 4k, DP at 100Hz, HDMI at 50Hz
OS: Ubuntu (I had bugs with PureOS, will retry eventually. Quebes wouldn’t boot for me, but I’m new to linux)

Important notes:

  • HDMI 1.4 supports 4k but not 21:9
  • HDMI 2.0 supports 21:9
  • Crowdsupply page stated the 15" would have HDMI 2.0. However, this hasn’t been confirmed anywhere I’ve seen. Even after asking in forums.
  • Intel 520 didn’t support HDMI 2.0 but could with a DP converter. We now have HDMI to DP converters as linked above. Be sure to note this is not DP to HDMI since we don’t have DP ports on the librem.

Though its off topic since it concerns Ubuntu, I’ll document what I did before I realized the possible graphics limitations.

  • Added 3440x1440 modeset to the xrandr profile in command line.
  • Revealed 21:9 as an option in the display system settings panel, but just blew everything up within the already displayed 16:9 resolution and the laptop was slow to respond. Mirroring off, laptop display off.
  • Invoking xrandr --output HDMI-1 --mode 3440x1440 from the command line it gave me the ‘configure crtc 0 failed,’ also failed when using crtc 1 and crtc 2 (the only other crtcs I saw listed in xrandr --verbose, though I didn’t exactly know what I’m looking at.)
  • Further, I got an error prompt in system settings panel saying the resolution failed when applying to “crtc 63” so I tried to invoke that and it said it didn’t exist. :lying_face:

I was thinking it must be a driver or refresh rate problem until I realized the reported limitations of the graphics… Who knows, maybe I wasn’t doing the xrandr profile correctly, though. I’m new like I said.

In case anyone is confused from where I’m coming from with the adapter, I’ll include this link that states a DP converter could add HDMI 2 to the Intel 520.

Edit: just realized we’re in the future and I have USB 3.1 Type-C. Looking into if this is what I should of been trying to use all-along. Any feedback appreciated!

I think the article you linked to is saying that you can convert DP to HDMI 2.0 for the case where you have a display that needs HDMI 2.0 but doesn’t have a DP input (e.g. a TV). So, you’re not enhancing the capability, just taking an output that already has the required capability and converting it to HDMI.

The adaptor you suggested converts the other way, and probably wouldn’t help you.

Intel says the maximum supported resolutions for the HD 520 graphics in the i7-6500U CPU are 4096x2304@60Hz for DP and 4096x2304@24Hz for HDMI 1.4. (Confirming that it’s not HDMI 2.0.) Going purely by that specification, 3440x1440 should work on the HDMI output at 24Hz and on DP at 60Hz.

So, it might work over HDMI if you can configure it to output at 24Hz, but the fact it hasn’t automatically detected that as an option doesn’t bode well.

USB type C sounds promising. If the Librem 15 v3 outputs DisplayPort over its USB C connector (and I can’t find confirmation of that), then you should be able to use a relatively inexpensive type C to DisplayPort cable to gain access to that output.

There’s also a chance that the type C connector provides Thunderbolt, which might open up the (expensive) possibility of using an external GPU. I don’t know how good the support for that arrangement is in the Free Software world right now; probably not great.

1 Like

Thanks for the insight, patch. I’m mostly a google warrior at the moment, all this is new to me.

I set a lower Hz but it didn’t work. While neither would change the output for me in terminal, only Ubuntu that offered the 21:9 in display settings (just messed up the resolution, wasn’t stable).

I tried a Type-C to DP cable and no input is recognized on display or computer. I’m guessing it’s not Alternate Mode spec, it would be good to have confirmation. I’m confused why a Type-C port was included in the specs without it - so maybe it could be missing the driver? I’m not knowledgeable enough to check for this. Tested on Ubuntu and PureOS.

My librem does give a firmware error on startup, pretty sure its the normal free-firmware installed and just warning the proprietary isn’t. There was speculation on another forum that the Alternate Mode driver could be included in firmware on a Windows system if that matters.

(Note for everyone: my understanding is both specific hardware and driver have to be present for Alternate Mode to work.)

I can’t claim to be much more than a google warrior myself!

You’re obviously right about needing both hardware and driver support to use the DisplayPort Alternate Mode. The hard part seems to be figuring out whether that support exists.

The output of lspci -k might be illuminating (or, equally likely, unilluminating).

Unable to resist further googling, I found myself looking at documentation for the Linux USB API. It seems that kernel 4.13 documentation introduced a section about the USB Type-C connector class, which includes some information about how USB C devices will be listed under sysfs.

So, /sys/class/typec/ seems like a useful thing to look at when trying to find out whether your hardware has been detected.

Reading between the lines, though, I get the impression that support for some USB C features is still a work in progress and perhaps you need a very recent kernel to enable support for Alternate Modes. Prior to 4.12, this documentation seems to contain nothing specifically about USB Type-C at all.

Maybe it will only work with the latest kernel (4.13), or a future release.

Late update: Support has confirmed: USB-C ports are 3.0 and do not support Alternate or Power modes, so the ports can only be used for regular usb data - flash drives, etc.

Would of been nice to know beforehand, oh well.

Well, our products page ( clearly states USB 3.0 support.

Yep, you’re correct, it’s there! I believe you helped finally get an undamaged librem in my hands, so thanks for that.

I was confused from the 3.1 spec still listed on crowdsupply. I knew the specs deviated during funding, but figured it was a sure bet they were finalized once shipping and assumed they were upgraded with more Type-A ports in newer versions after looking at the new product page. So just a misunderstanding and assumption a downgrade wouldn’t of happened and the crowdsupply specs would be correct. Deleting or correcting the crowdsupply page could prevent someone else from making the same conclusion - I get its a lengthy assumption looking back on it though.

Thanks again.

You are right, I’ll see what we can do about it.