Help wanted, can't boot into graphical install

yes, i’m stuck, i’ve switched back to coreboot, sucessfully booted into graphical install, but now, after the install, the boot process of debian is stuck at :
Loading initial ramdisk
i’m totaly lost

Have you tried the text install?

yes … i’ve tried that, graphicall and live
Under pureboot i can’t boot into text or graphical
Under coreboot i can and i’ve installed debian with non free firmware, to be sure, with graphical but now i can’t boot under the debian i just installed

Maybe now try tty and see if you can at least log in? If you can, you can try starting your display manager from there.

No, i can’t boot
the boot process stop at “loading initial ramdisk”

Does the boot process stop, or does it just quit showing info? If the display manager is failing to load you’ll see a similar result. I could be wrong, I’ll admit that, but a quick Ctrl + F1 or F2 will answer the question.

It freeze at the step loading initial ramdisk ctrl f1 or f2 doesn’t do anything

Well, at this point, you might as well try pureos.

Ye but that’s weird, why an os as simple as debian, won’t work, and i don’t like pureos, i don’t like gnome, nor kde, and there is too much things by default :frowning:
Anyway, still open for an anwser

1 Like

Its true, I would think it should boot since pureos is a close derivative. Sadly I’m not smart enough with the boot process to know what the problem would be though.

Yes, i’ll try pureos, maybe the grub config will help me
Thanks for the help !

Heh, you mean the “help”. But you’re welcome regardless.


So i finally have installed devuan under coreboot

  1. Installed pureos, copy the grub.cfg into a usb,
  2. Install devuan
  3. boot into a pureos liveusb, copy the grub.cfg into the /boot of devuan while changing for os / intrd … names
    It work

But i just flashed pureboot from the /firmware/utility/ of gitlab, aaaaaaand it seems that i can’t boot into devuan, and that any usb are not recognize
I’ll try with other usb key tomorrow, and if not i’ll flash the bios with a ch341a_spi to put coreboot back, build from head github repo and reflash


So it turns out it weon’t boot more than one time
I’ve put back coreboot, installed devuan, boot, do my setup, reboot and the it doesn’t work. When i try to live usb with pureos, i reset the grub.cfg as the exemple of pureos, but still it doesn’t work
Any idea ?

It’s a grub mis configuration, i fixed that, changed to heads (pureboot) but it seems that heads doesn’t want to boot the same kernel with the same working (under coreboot) grub.cfg …
Any help ?

Not that I’ve tested this (nor having intention to do so), but please download /devuan_chimaera/desktop-live image and follow this guide: Also, please do not forget to create:, as described here: Installation failed - please help. Hope this helps you.

While this correct just follow above guide (not quite the same as Calamares installer but thing is … to make this thing work on your Librem 14).

Thanks for this answer, but i don’t use gpt but mbr
I’ll try tho

1 Like

So I have more info by changing the rom from official utility gitlab purism repo to heads github repo and resetting to default value
this is what i get
sha256sum: can’t open ‘./vmlinu…’ No such file or directory
Same but for initrd
The two file exist, are place in /boot/ and the names are good

If it can help …

Please be aware of this input (read it carefully):