Help wanted, can't boot into graphical install

So I finally have a librem14. Very happy with it and coming from a T430 with heads, it’s very easy for me.
But I have one issue. I’m trying to install another OS (devuan, debian bullseye without systemd), but the boot process of the iso on usb (i’v tried usb-c and usb a) stop at "kexec /media/d-i/vmlinuz --initrd=/media/d-i/initrd.gz --append=“append append intel_iommu=igfx_off
Starting the new kernel”
And then it freeze.
I’ve tried debian also but same issue. I’m using a netinstall iso, without gui
For the usb, I’ve download the iso, veriify the hash, and used balena etcher.
Is there something I’m missing ? I’m doing everything I would do on an install of an OS on
my t430 with heads
I’ve read the Help installing OS on Librem14 issue, but thing is, i can’t even install the os i want, i can’t boot on the usb key.
Thanks in advance for any help !

1 Like

Way beyond my pay grade but reading Broken Librem 14 boot process suggests that other operating systems are possible but install challenges are also possible.

It probably matters whether you have the Coreboot firmware or the Pureboot firmware.

thanks for your answer, but thing is i’m able to install via live desktop.
So the only issue i see here is the graphical parameter that isn’t passed to the kernel/kexec while booting in graphical install, but is passed when live booting.
Any idea on how to pass this argument tho ? i’m not an epxert at grub

1 Like

I’m guessing, but I believe your issue is a lack of correct GPU driver. I think it uses software rendering on the live boot, so you could try that and then update.

Alternatively, when it freezes you could try dropping to tty, then you’d at least have a terminal to work with.

Yes , i also think it miss the correct driver … would you know where, and which one i have to add ?
also i just tried to get to the tty, i can’t it’s just frozen

If it’s frozen then it’s hard to say, could be something else. You could chroot from your live boot and check dmesg or jounalctl, but I am no expert when it comes to that, sorry to say.

yes, i’m stuck, i’ve switched back to coreboot, sucessfully booted into graphical install, but now, after the install, the boot process of debian is stuck at :
Loading initial ramdisk
i’m totaly lost

Have you tried the text install?

yes … i’ve tried that, graphicall and live
Under pureboot i can’t boot into text or graphical
Under coreboot i can and i’ve installed debian with non free firmware, to be sure, with graphical but now i can’t boot under the debian i just installed

Maybe now try tty and see if you can at least log in? If you can, you can try starting your display manager from there.

No, i can’t boot
the boot process stop at “loading initial ramdisk”

Does the boot process stop, or does it just quit showing info? If the display manager is failing to load you’ll see a similar result. I could be wrong, I’ll admit that, but a quick Ctrl + F1 or F2 will answer the question.

It freeze at the step loading initial ramdisk ctrl f1 or f2 doesn’t do anything

Well, at this point, you might as well try pureos.

Ye but that’s weird, why an os as simple as debian, won’t work, and i don’t like pureos, i don’t like gnome, nor kde, and there is too much things by default :frowning:
Anyway, still open for an anwser

1 Like

Its true, I would think it should boot since pureos is a close derivative. Sadly I’m not smart enough with the boot process to know what the problem would be though.

Yes, i’ll try pureos, maybe the grub config will help me
Thanks for the help !

Heh, you mean the “help”. But you’re welcome regardless.


So i finally have installed devuan under coreboot

  1. Installed pureos, copy the grub.cfg into a usb,
  2. Install devuan
  3. boot into a pureos liveusb, copy the grub.cfg into the /boot of devuan while changing for os / intrd … names
    It work

But i just flashed pureboot from the /firmware/utility/ of gitlab, aaaaaaand it seems that i can’t boot into devuan, and that any usb are not recognize
I’ll try with other usb key tomorrow, and if not i’ll flash the bios with a ch341a_spi to put coreboot back, build from head github repo and reflash


So it turns out it weon’t boot more than one time
I’ve put back coreboot, installed devuan, boot, do my setup, reboot and the it doesn’t work. When i try to live usb with pureos, i reset the grub.cfg as the exemple of pureos, but still it doesn’t work
Any idea ?