Help with dialing to #5005*7672# requested

I cannot send SMS messages when on 4G.

I’m trying to check if the “SMS centrale” (I guess this is the Service Center Address / SMSC Address) is set correctly on my Librem 5.

Therefore I have to call: #5005*7672#.

This does not work due to this bug.

So I tried to use kermit to dial the number above, and set the “SMS centrale” correctly by dialing **5005*767231624000226#.

I have this in my ~purism/.kermrc file:

set escap 21
set line /dev/ttyUSB3
set carrier-watch off

Then I do this on the terminal (complete copy, including responses):

$ sudo kermit ~purism/.kermrc
C-Kermit 9.0.305 OPEN SOURCE: Alpha.02, 19 Sep 2020, for Linux+SSL+KRB5 (64-bit)
 Copyright (C) 1985, 2020,
  Trustees of Columbia University in the City of New York.
Type ? or HELP for help.
(/home/purism/) C-Kermit>c
Connecting to /dev/ttyUSB3, speed 9600
 Escape character: Ctrl-U (ASCII 21, NAK): enabled
Type the escape character followed by C to get back,
or followed by ? to see other options.

+DISC: 8,0,0,31,"#5005*7672#",129

+DISC: 9,0,0,31,"**5005*767231624000226#",129

+DISC: 10,0,0,31,"#5005*7672#",129

It looks to me that the numbers are not really dialed, because I see no feedback of the set number. Am I correct, or do I something wrong?

That code is a part of iPhone’s user interface and has nothing to do with any other phone.

Thanks. Do you have an idea how I can read and optionally set the Service Center Address / SMSC Address on the Librem 5?

Answering myself, by typing: AT+CSCA? in kermit.
And I could confirm that the SMSC is correctly set.
The provider I have is Simpel, and in the Netherlands they operate on the T-Mobile network.