Help with Python3 needed please

Folk I have the following problem:

This is a command with an output:

sherab@sherab-librem:~/qutebrowser/scripts$ python3

==================== Creating virtual environment ====================
$ rm -r .venv
$ python3 -m venv .venv
The virtual environment was not created successfully because ensurepip is not
available. On Debian/Ubuntu systems, you need to install the python3-venv
package using the following command.

apt-get install python3-venv

You may need to use sudo with that command. After installing the python3-venv
package, recreate your virtual environment.

Failing command: [’/home/sherab/qutebrowser/.venv/bin/python3’, ‘-Im’, ‘ensurepip’, ‘–upgrade’, ‘–default-pip’]

following the advice to install python3-venv here’s more command with more output:

sherab@sherab-librem:~/qutebrowser/scripts$ sudo apt-get install python3-venv
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-venv : Depends: python3.7-venv (>= 3.7.3-1~) but it is not going to be installed
                Depends: python3 (= 3.7.3-1) but 3.7.5-3 is to be installed
E: Unable to correct problems, you have held broken packages.

but from this command you can see that there is python 3.7.3-1 on my system

sherab@sherab-librem:~/qutebrowser/scripts$ apt list python3 -a
Listing... Done
python3/now 3.7.5-3 amd64 [installed,local]
python3/amber 3.7.3-1 amd64

So why is python 3.7.3-1 it not available??

Did you do a sudo apt update before trying to install python3-venv?

I would try sudo apt install -f I think, then retry sudo apt install python3-venv.

I just did

sudo apt update
sudo apt upgrade
sudo apt install python3-venv

and all worked out. After apt upgrade, I was at python 3.7.3-1, and I got no complaints about installing python3-venv

No luck
thanks for helping

still no luck

Maybe you tried this, but I would next try

sudo apt update --fix-missing
sudo apt install -f

And if that doesn’t do anything, maybe

sudo dpkg --configure -a
1 Like

I had to re install system
thanks for helping!