Help with wifi connection

I got my L5 a few months ago, but hit a block and haven’t been able to figure it out in the few times I’ve had a moment to poke at it.

I wanted to get it set up and test the UX and available apps before connecting it to my carrier. However, I can’t get it connected to the (enterprise) WiFi. I can’t even get the “connect” button to be active. I suspect the issue may be related to certificates because the CA certificate has “none” and the only option in the drop down is “select from file”. Of course, I can’t put a file on this to load from if I can’t get it on the network in the first place.

Any help is appreciated! I’m not a tech noob, but I am used to not needing to set all the options.


In the past, WiFi connection problems were related to an incorrect date, time, and time zone selected, so you might want to check that in the Settings app. If it’s wrong, you might have to disable automatic and then set them manually (the first time). After that you can revert to automatic.

If that’s not the problem, and you’re sure the kill switches are not engaged, you might try flicking them the opposite direction, waiting a half minute or so, then flicking them back. (When they’re all in the “up” position, i.e. toward the top of the phone, then they’re not blocking any circuit.)

1 Like

Can you get it connected to any WiFi? For example, it works at home but not at work?

Or not. You can obviously get files via a carrier. You can plug a disk into the phone (USB port) and get files that way too. Heck, you could even use the uSD card.

But there’s no point worrying about getting files onto the phone until we can narrow it down as to what specifically is going on.

1 Like

You are (probably) about to use next level of Certificate-Hardened WPA2-Enterprise setup/authentication (PKI based one)? Cannot help, but (if so) please let us know how you managed to establish this kind of WiFi connection. Please read as well: (hope this article helps at least as orientation).

Can you get it connected to any WiFi?

Actually, I don’t recall if I connected it at home. I probably did, but with two teen-aged sons who like to futz with things that aren’t theirs (We call them the racoon and the baboon.) who were doing remote school, I couldn’t keep it at home while I was at work. I’ll have to verify that it works at home.

The wifi is definitely on because I can see the multiple networks in play listed.

I understand the evolution of WiFi security if not all the details. My workplace has a couple WPA2-enterprise WiFi networks. Definitely not WPA3. I don’t think we have anything special because iThing/Android/laptop devices usually don’t need any adjustments from the default settings. Users just enter their credentials and go.

Years ago, some Windows machines would need to install/trust a non-standard root cert, but I haven’t seen that it a long time. Does the L5 not have any built-in, trusted root authorities?

1 Like

Now that I say that, I do remember connecting at home. Also, I can connect to the limited, “guest” network at work, so the WiFi is functional.

On that guest network, I am getting an error about an incomplete TLS handshake on the phone app upgrade. I also don’t see any other updates showing, even though the phone has been off any network for at least 4 months. Shouldn’t there be some other updates? That seems like a long time without improvements for a still-being-polished device. Did they quickly install in the background before I noticed?

There should definitely be updates available.

On the WiFi network, try running sudo apt update in the terminal to see if it returns any errors.

1 Like

Yes, common (automated) ones (129) are present within this Linux phone:
apt list ca-certificates
sudo update-ca-certificates
ls /etc/ssl/certs/

Another example would be:
ls /usr/share/ca-certificates/mozilla/

sudo apt update says (after a few seconds) that “96 packages can be updated”. When I then refresh the updates in the store, a bunch appear (which did not happen previously). However, there is no obvious way to start them.

How do I tell it to install all the available updates? Preferably in the GUI. I’m comfortable enough with the terminal to follow instructions, but not familiar enough to do much on my own other than move around, and I will always be nervous about mistyping on a tiny touchscreen keyboard and blowing something up.

In the GUI, at the list of updates there should normally be a blue update button. If you don’t see it, back to the terminal and run sudo apt upgrade to install those 96 packages.

You said you’ve had the phone for several months, so it would be useful to know which repository it’s on, amber (older) or byzantium (latest). Can you go to the store app again, click on the hamburger menu at top, then Software Repositories, and report here which it is?

Don’t worry. If it’s mistyped, it will be rejected as an unknown command.

1 Like

After: sudo apt update command, I’d recommend to run:
apt list linux-image-5.16.0-1-librem5
sudo apt install linux-image-5.16.0-1-librem5
sudo reboot

Thanks to all who responded. It is working now.

Once I was on the “guest” wifi, I was able update. It took several rounds of updates and reboots both in the terminal and the GUI.

Once I was updated, the path to the certs (thanks @Quarnero!) was invaluable as I had to point to the exact cert (which is the part that is very different from the mainstream where the correct cert is auto-discovered). Once that was done, it worked. I tried pointing to the cert before updates and it still wouldn’t work.

With WiFi and email (and phone when I transfer my sim), I just need to say goodbye to Pathos ( on my current phone and I’ll be good to go.


You can always enable the SSH server on your phone and then SSH in from a full-sized laptop / desktop.

Or you can dock your phone if you have a suitable dock (like the NexDock range).

Just for fun …

You can also plug in a USB ethernet dongle to the Librem 5 and thereby be on the network even if WiFi is proving troublesome. For me this worked out-of-the-box with a dongle that I bought some years before I received my phone (i.e. the dongle was chosen at random, not for compatibility with the Librem 5).

1 Like