Hopefully quick LTE clarification

If my Librem5 is currently on my mobile network (Mint / T-Mobile) and:

  • The top bar shows 4G
  • The web browser works fine
  • Text messages work
  • mmcli shows access tech as lte

But if I go to make a phone call it quickly says “Call Ended” and journalctl says:

Couldn’t create call: QMI protocol error (13): ‘NoNetworkFound’ (domain: g-io-error-quark [36])

What could I try next?


Recently the phone has started having an issue connecting to 3G network saying:

network reject indication received
service domain: cs
radio interface: lte
reject cause: cs-domain-not-available

So I thought maybe it was time to always force it to 4G and feel like I’m really close, but the phone call part is really important… :slight_smile:

Voice over LTE (VoLTE) is not on by default. What could be happening is there are no 3G or 2G towers to complete your call. You can try to activate VoLTE and see if that improves the situation. I don’t have the instructions handy but if you search the forums you may be able find them posted.

Hi, I ran the AT commands that Kyle defined in another post:

To Enable VoLTE:

sudo screen /dev/ttyUSB3

but I didn’t really see anything change. The access tech already said lte, which made me wonder if that is actually signifying the same thing.

Sounds like that’s just for data.

I had the exact same thing happen to me.
To enable volte I went here: https://source.puri.sm/Librem5/bm818-tools/-/merge_requests/1/pipelines

then click actions and download artifacts. unpack the zip file and try to open the deb file inside. It should open gnome-software to install it.

You may need to reboot the phone to get it to show up, but it should give you a bm818 volte app that you can use to activate volte and it will also check that it’s enabled.

edit: You may need to power cycle the modem and/or reboot the phone after enabling volte.

1 Like

Thanks @steve, but I think that is where I’m getting stuck when I try to pull down the artifact it says ’
Could not load artifacts.’

I’m logged in too…

I think I might just try to pull down the script they have in the repo and give it a go kinda manually

try here the top one: https://source.puri.sm/Librem5/bm818-tools/-/pipelines

1 Like

Ok went through with that and still getting same result (Instantly going to Call Ended. NoNetworkFound). In the other thread it mentioned stuff about firmware version? I also saw mention of checking the FW in the gui app, but for some reason the gui tool couldn’t open up the display so I ran that manually too!

+BMSWVER: M100E_YCSN0_1.0.0_210830,YCSN0_M100E_1ACD_B325_V1.0.0.1_20210907,M100E_1.0.4_200715

+MSWVER: M100E_YCSN0_1.0.0_210830,YCSN0_M100E_1ACD_B325_V1.0.0.1_20210907,M100E_1.0.4_200715

and also running the ATI command with screen shows:

Model: BM818-A1
Revision: M1.0.0_e1.0.0.1_A1.0.4

Maybe that will help someone… Thanks again for your time and thoughts!

1 Like

Bear in mind that if VoLTE is not enabled then the top bar will change during a call. It will show 4G when not making a call and will drop down to e.g. 3G during a call.

So the above-quoted statement needs to clarify whether you are talking about the top bar during a call or when not making a call.

I think you have to power cycle the phone after those AT commands. Did you do that?

I think that is a consideration too - but I have no idea what the firmware version is supposed to be.

One other thing to keep in mind is that you need to enable Mobile Data in the Settings app for VoLTE to work. Are you able to browse the web when wifi is disabled/not connected?

Yes, mobile data is working great.

I tried digging into this VoLTE calling issue more tonight. Since the bm818-tools utility confirmed that VoLTE was enabled and without a better idea I figured I’d continue down the talking to Modem directly to figure out if I could learn anything new.

In the end, the ATD(phone number) command returns: NO CARRIER

AT+CEER returns: No cause information available

AT+COPS? returns: 0,0,“Mint”,7

AT+CEREG? (Seems like this is the important one for volte)

all returned: 0,1

Doesn’t the ,1 mean it is registered?

AT+CGDCONT? returned a line that has the ims information.

So I don’t know if any of that is relevant, but seems like registered for a volte voice call seems completely different than the rest of it, because I certainly have a carrier connection if I have IP addresses & text messaging working?

So I guess the scary question is If the carrier didn’t accept this modem for VoLTE use, wouldn’t the CEREG response be different?

Is there any chance that:


aren’t the right values for T-Mobile?

In the end, it would be neat if any of this research could help make the top status more realistic because a normal user would look at this screen and say everything is good and that’s not the truth.

Thanks again for any help!

Once the transition from 3G to 4G is complete, the status will basically be realistic. The phone will either say 4G or nothing, and if it says 4G then calls and data will work.

The transition process involves all parties getting from “A to B” … carriers, modem manufacturers and software developers. Clearly we aren’t there yet.