How do I Delete Password in APN settings


  1. Was told to add username and password to the APN settings.
  2. When that didn’t work either, I contacted carrier.
  3. Carrier said they doen’t use username and password in APN.
  4. I tried to delete username/password.
  5. Cannot Save change now unless there is at least 1 character in the password box.

Carrier says:

Koodo’s APN does not use a user id and password. If the fields are present in your phone they should be left blank.

ISSUE. I can’t “make them blank”. Deleting them prevents saving the changes.


Sounds like a problem (bug) in the GUI then, that it does not allow you to make them blank.

As a workaround, you can try editing the file where that configuration is stored, look in the directory /etc/NetworkManager/system-connections/ where there should be one file for each connection, the filename should be like the connection name. Inside that file, you can probably remove the lines mentioning username and password, then reboot to make the changes take effect. Maybe save a copy of the file somewhere before editing it.


… which to be clear will require root access i.e. sudo

What I did was reflash a new Evergreen image. A little drastic, but it gets the job done.

Is this in settings under mobile and access point names? Is it possible to add a new APN with the “+” sign without username and password, and forget about the old one containing a password?


You can delete the APN from the advanced network settings app: just select the faulty APN, then press the minus ’ - ’ button on the bottom corner

1 Like

Thanks. That got rid of it. I retyped the APN name, and can now send text as before. Searching here, I see a lot of similar issues trying to send/receive text with image. Doesn’t seem to be a fix yet.

The"Send SMS" works
The Send SMS/MSS opens create a group.

Do you know where we enter the MMS© data?
I also viewed today’s 14,776 lines of the log. Lots of warnings and errors. Nothing makes sense.

Chatty–>Preferences–>MMS/SMS settings

1 Like

Ah. I just realized that the editor for this thing decided that bracket @ bracket has to mean the copyright (@) symbol.

The confusion was/is MMSC .
For me, it’s the reverse “SMS and MMS” > and under MMS Carrier Settings it asks for MMSC :confused:
It’s all sorted out now. I think. At least it now sends/receives text w/ pics.

It’s getting better and better as we go.

1 Like

Yes, that is forum software behaviour - and annoying.

(a) first
(b) second
© third

A workaround appears to be to put a backslash in front of the closing (right) parenthesis

i.e. you type (c\) and you get (c)

There are other workarounds but they are more work, more obscure, more hacky.

1 Like