How Do I Force L5 To Use 3G Not 4G?

How Do I Force L5 To Use 3G Not 4G?

My modem works from work from 2.4 up to 5G.
Top left of screen shows 4G
Posts on Reddit suggest some phones are fixed by turning/setting phone to 3G, not 4G that is displayed here as being used.

This happened to me. I went into my SIM card settings > Access Point Names > Koodo

Reddit user: Here I changed my APN protocol to IPv4…when it was on IPv4/IPV6, I wasnt able to send pics, but by changing it, I was.

I don’t see a setting to change L5 IPv4/IPV6 - is there none?

~I changed to 3G and only have 2 bars instead of 5.

I don’t know anyone that can send and receive tests from me except one, and they are restricted from phone 12 hours of each day.So testing is long term.
I shall persevere.

1 Like

It is in the GUI settings for the mobile service. But you really don’t want to do that. The 3G network is being shut down globally. Whatever short term gain you might make by using 3G, you will lose it completely sooner than you would like. If you want to pursue that then ask your cellular provider whether they have already shut down 3G and, if not, what date they plan to do so.

2.4GHz and 5GHz are the frequencies of the WiFi. They are not the generations of the cellular modem. The generations of the cellular modem are 3G and 4G. (There is no support for 5G in the particular modem but 5G is also a valid generation for mobile service.) And, yes, this is unhelpful terminology, and you are not the first person to mix it up in this way.

As an aside, no matter what cellular generations you select, your provider can override that i.e. by refusing the combination that you chose until you “choose” the combination that they chose.

The first thing to check is whether your provider even offers IPv6. There is no need to disable IPv6 if there is no IPv6 being offered by the provider.

Note that the choice to use IPv6 or not applies independently to each of the WiFi and the cellular connection. More generally, that choice applies independently to each network interface.

If you are experiencing problems and your provider supports IPv6 and your end supports IPv6 (and it is the case that Linux has supported IPv6 for decades) then it can definitely be valid troubleshooting to disable IPv6.

Using the ifconfig command will show whether IPv6 is even happening. Lines starting with inet6 tell you whether IPv6 is happening on that network interface (for each network interface).


PS MMS may cease working at the provider end if you use a VPN.


What have I got to lose?
Even now, it refuses to delete chats. Who owns this? Me or Chat? (rhetorical). Maybe it’s been Googlelated.

I’m sure there is a more in depth delete method to delete from the command line. I won’t bother because Chat doesn’t work anyway.

Of course. But I am not worried that it won’t work, MMS already won’t work! :woozy_face:


1 Like

Be forewarned that your mileage may vary and this may not have the intended result you are looking for, but since you asked:

Settings > Mobile > Network Mode > 3G Only


I was trying what a fellow said he did that worked for him.
Maybe I should provided more detail, but my intent was and I did it, was to force 3g. Shut down, reboot and I received a bunch of texts, with images (6) though one was a copy of the other.
I tried sending/receiving text w/ image, that failed as usual, but I went to the next step he performed and that was to force it back to 4g only - which I did. No success with text & pics.

I have also followed another bit of advice and that was to remove the sim card wait a bit and put it back - that had worked for someone else. But not me.

Thank you for help JCS

1 Like

For whom ever is interested, and @irvinewade @amarok @JCS, the above procedure seems to have chased a gremlin or two. Here is what I did to get some texts with pics.

Preamble I n Short:
To get pics with texts I forced 4g to 3g only. Rebooted, pic came in. Rebooted, switched to 4g only. Rebooted It pics come in.

Step x Step

  1. List item - Set to use 3G only. Reboot.

  2. List item - Use Chat (I know, 3g is for WiFi - hear me out)
    When I opened Chat soem texts with pics showed up. :astonished: To add something stranger, each Chat had a duplicate and duplicated pics.

  3. List item - When this was calmed down, I deleted all Chats. Reboot.

  4. List item - Push 3g only back to 4g only Reboot.

  5. List item - Back to Chat and now pics come in with texts. Sort of.

  6. List item - In same room, a friend ends me a text, then text with pic (80KB). The text came in right away. The text with pic came in 2 days layer. Other texts, days old with a pic also came in. Hours later, still waiting for today’s text/pic to arrive. Maybe in a few days.

This is 3 days later, and the pics came in.
Of note is that they are in no chronological on the Chat screen.
A total of 6 copies of one pic courtesy of Chat. I blame Chat, not the carrier because Chat places received text and texts with pics in random order, mixed into all the Chats I have asked Chat nicely to delete, and does …until the next boot.

At some point in time Chat pics and texts are going to keep adding up unless I never boot again. Wow.

It’s as close as to receiving pics as I can get. Sending pics? - nope. Half way there!

Hey! Why don’t we start a crowdfund and make Byzantium work before continuing with another train wreck!

1 Like

That’s “interesting” (in a bad way, I mean). I don’t know what’s going on there.

FWIW - and of no comfort to you, I’m sure - all of byzantium, including Chats works fairly well for me. It was a significant improvement over amber.

But then I haven’t tried setting up MMS, since the particular carrier’s SIM I have in the Librem 5 isn’t MMS-capable anyway, nor is it VoLTE-capable. Some time ago, I did briefly try my main SIM card from a different carrier, and everything worked well, as I recall.


Is it for sale? :slight_smile: Actually, this all about me :selfie:

More goofiness for this one,

Pics don’t work any more. Of interest maybe, is that when in 3g only, I have 2 bars showing signal strength, but in 4g, all 5 are full. I get why that it is.

Since moving back from 3g/4g to 3g-only and back to 4g only, copy of pics came in, since then - no pics via Chat.

[Interesting event]
I just tried noticed Wi-Fi is X’d off. So I pulled the Notification/Shut-done etcetera screen down, and tapped the Wi-Fi icon, nothing. - tapping the Mobile button, Torch, anything and nothing happens. The one things that does work, I hope, is Power Off - but it takes about 2 minutes and then the “librem” appears and that took another 2 -3 minurtes to disappear.
[/ Interesting event]

It also appears that with all of those attempts to flash and the last one was successful using corrected steps, Chat did not delete chats w/ pics. It just deleted the pics so I get the ‘no image’ icon, but Chats text is still there :thinking:

I’ll look around to see if there is more direct way (terminal(?), as the crow bullet flies before flashing again today using a image on USB set up using Ubuntu.

1 Like

If you want to try a “nuclear” option, here’s something that I tested successfully just now, but do it at your own risk:

Inside the directory /home/purism/.purple/chatty/db there is a database file called chatty-history.db that contains all your chats (excluding any chats from an XMPP account you might have set up). Cut this file and paste it somewhere else for safekeeping, e.g. in the main Home directory or an attached USB drive, etc.

Restart, open Chats and confirm that it’s empty (except for XMPP chats, if you’ve ever added an XMPP account). A new, empty chatty-history.db file will have been generated. Now you can start testing SMS and MMS to see how it behaves.

You can move the old chatty-history.db back to its original location if you want; just replace the newly-generated .db file with the old one (including the old SMS/MMS), and reboot.

Note the .purple directory in the top of this comment. You won’t see folders that begin with a “.” unless you choose “Show Hidden Files” from the Files browser app.


Not to worry. I’m not concerned about the risk of losing -stuff- because there’s nothing I’d put on it that isn’t trash-ready, except settings, which I have copies of.
It’s good that you put the caveat there in case anyone else reads it looking to clear their chats/folder.

Thanks for the nuke’em tip.