How do I get ufw firewall to enable by default?


#1

Librem 15 v3.
When I recently got the device, I sudo enabled the ufw in the terminal and confirmed with a verbose command. I presumed it would always default to enabled on reboot, but it doesn’t. I installed Gufw to see if that would help, but no. It just makes it easier to turn on when I reboot or start up.
Please help. Thank you.


#2

I would look for some ufw guide for Debian (PureOS is derived from Debian, so most Debian guides work).

sudo ufw enable 

may be what you need.


#3

Thank you for the reply.
That command enables it for the active session, but if I shut the computer off, and power on again later and check ufw, it’s inactive.
It won’t stay on by default.
Does yours?


#4

Not that I am personally a fan of UFW in any way or support its use but

sudo systemctl enable ufw

should cover the usage that you are trying to do.


#5

Thank you for your help.
Seems that’s not working for me either.
I’m a Mac guy but migrating to Linux and still learning. What do you use for your firewall?