How do I switch to gnome-shell on a Librem 5?

I want to try GNOME Shell on a Librem 5 device. I installed gnome-shell with dependencies with apt. When booting, I see GDM for a few seconds, but it is quickly replaced by the usual numeric password screen. Could someone suggest what else I need to change to login via GDM?

1 Like

I am not positive hear, but I think sudo systemctl disable phosh and rebooting will get gdm to display properly.
Since Phosh doesn’t use a Login Manager, I think what is happening is that gdm is starting up and then Phosh is starting over top of it.

To be clear though, I am not sure how well gdm/GNOME will work though and you may need to re-enable and re-start Phosh if you want the phone to go back to normal. (and maybe also disable gdm)

1 Like

Thank you. The phosh service disabling allowed access to GDM.

By default, GDM logins to Phosh. When the cursor is in the password field, the “:gear:” menu appears as usual in the bottom right corner. If I hide the on-screen keyboard, I can see it. The other option was “System X11 Default”, however, looping back to GDM.

I installed mutter, but it seemingly had no effect. Installation of the gnome meta package added the usual “GNOME” (which implies “GNOME on Wayland”), “GNOME Classic”, and “GNOME on Xorg” sessions to the “:gear:” menu. I am not sure what dependency helped. Only the Wayland option worked.

The result looks promising, but it inherits some tweaks from Phosh, which I do not know how to turn off or reset. The screen is scaled to 200%. I can scale it back in “Display” settings to 100% in Phosh, but not in the GNOME session. Another issue is that the windows have no title bars and cannot be dragged or closed (unless from the tasks view).

I suspect that I need to go to the Librem 5 part of the forum if I decide to discuss possible fixes.