How do I take picture on the librem 5?

I’m currently running byzanium and have installed megapixels on my librem 5. However, it fails at launching megapixels with this error:

/usr/share/megapixels/config/purism,librem5r4.ini not found
Could not find any config file

I tried to find it with apt-file, but that tells me it’s cache is empty and can’t find anything no matter how many times I run apt-file update.


How did you install megapixels?

I think it should work if you use Dorota’s megapixels version from here:

1 Like

just apt-get install megapixels

OK, that might explain it, then probably you are getting the megapixels version 0.13.1-2 straight from debian, that one is perhaps not working out of the box on the Librem 5 yet.

If you want to try Dorota’s version that should work on the Librem 5 already now, you can build from source and install it like this:

sudo apt install git
git clone
cd megapixels/
sudo apt-get build-dep .
dpkg-buildpackage -us -uc -b
cd ..
sudo dpkg --install megapixels*.deb

At least that works for me.


Thank you that worked. Though it’s just sees a black screen. I’m guessing this means I need a newer kernel for the drivers. I think I’ll wait until that gets included in the updates.

edit: and yes the kill switch is in the stte that should allow the camera to work.

Are you sure? Look closely :slight_smile:

It should work with the default kernel in byzanium. For me the image is very dark so it might look black at first but if pointing it at something bright like a lamp or out the window, then I see an image.

Pointed it at a light, still just sees black

Figured it out, If I boot the Librem 5 with the hardware switch off for the camera, it never seems to see the camera. However, if I boot it with the switch on all works fine even if I switch it off later.