How to enable and use the Librem 13v2 / 15v3 touchpad's "middle-click" gesture feature?

I have tried to use several different OS’s on my Librem 13v2 (e.g., Linux Mint, Ubuntu, Pure OS 8, Debian 9 Stretch), and have noticed that only with Debian-based distributions are the touchpad middle-click features enabled (e.g., middle-click paste, middle-click opening new tabs).

I was wondering if there were some driver missing from Ubuntu-based distros that I could install, to make middle-click work as desired, or if this just a limitation of the hardware/software combination. Thanks!

1 Like

I tested on on Fedora 26 (so, not Debian-based, unlike all the others you mentioned), and all the gestures, including middle-clicking (three-fingers tap) worked just fine, whether on Wayland or in X… I did not try desktop environments that are not GNOME 3, though. You must enable “tap to click” in the GNOME Control Center’s touchpad settings, however.

I realize that now; I was trying to actually click the middle of the touchpad, which actually worked in Debian-based distros, but when tap-to-click is enabled, I was able to do the three-finger middle-click.

Cool, will consider the problem solved then, retitling the thread for clarity :slight_smile:

1 Like