How to factory reset?

I want to do a factory reset on my Librem 5. Is it possible?

I am not aware of a possibility to factory reset it just as we know from other smartphones yet.
But you could just reflash it with a factory image:

1 Like

Thank you for the pointer. I cloned librem5-devkit-tools and installed uuu per the instructions. When I run ./scripts/librem5-flash-image it throws an error:

File “scripts/librem5-flash-image”, line 17, in <module>
import tqdm
ModuleNotFoundError: No module named ‘tqdm’

I tried “pip instgall tqdm” but pip (nor pip3) is not installed, and “python --version” says Python 3.7.3. Python 2.7.16 is also installed on the system.

I’m doing this on a Librem13 with the latest updates.

Librem5-devkit-tools should be packaged in PureOS, try searching for “librem5” in the repos. This will pull all the dependencies whe installed.

Either way, you will need those packages:

One way to move forward in this kind of situation is to look for packages called something like that:

apt list | grep tqdm

which might show for example that there is a package called “python3-tqdm” or similar, then you could do sudo apt install python3-tqdm and after that try running the failed flash script again.

I think you will probably also need sudo in front of the ./scripts/librem5-flash-image command, like this:

sudo ./scripts/librem5-flash-image

At least that seemed to be necessary for me, without sudo it failed in the second part, when the actual flashing to the device is to start, then it apparently did not have permissions for that.


Thanks all for the tips. I’m reflashing now!

1 Like

This is probably the most important topic in this forum. I can’t remember how many times I wiped and installed both Windows and Linux in my early learning curve, and even sometimes still now, as a more advanced Windows and Linux user. You have to take risks as you learn. If it’s ‘game over’ the first time you cause a fatal error on your Librem 5, I fear that I will be too cautious to learn as I go. The first thing I want to learn is how to get the Librem 5 back to its factory default state, after I screw everything up. And undoubtedly, I will screw it up sooner or later. I never got good at rooting Android phones because you have no safety net on a locked, proprietary phone. If you brick an Android phone, the manufacturer just figures you got what you deserved and they won’t bail you out most of the time. So hopefully getting the L5 back to a factory default state will be made easy for everyone early on.

1 Like

Nope, the L5 is unbrickable, and was always intended to be unbrickable.


It should be easy for the average guy too. I can follow almost any reasonable instructions. But most people won’t get very far from a bash prompt unless you spell out every letter and hyphen for them.

Hi all
Today, I want do flash my librem5 new, because I want to do a factory reset. From what I know is, flashing the device, is the only way to do a factory reset. So I follow this process: But sadly, I ended withe following error:

Does anyone have an idea how to proceed now?

You might miss the following step:
sudo apt build-dep . .
Use the following instructions. I used them yesterday and they worked like a charm:

In case someone from Purism reads this - it is confusing when there are different instructions lying around on the official Purism websites. It would be better if you keep such stuff on 1 single place and put references to it on the other places so that there is always one single up to date source of truth.

Could you link to the different versions so we can take care of them?


sudo ./scripts/librem5-flash-image --variant luks

This will have the side effect that you’ll get full disk encryption (but with a vulnerable key).

makol1995 used this version and got stuck:

I used this version and it worked:

And there is also a YouTube Version here:

So there are at least these 3 official Purism sources for solving the same task.

1 Like