How to get full rights in PureOS 10 ?

The developers call the system “free”. however, the first thing I encountered was the inability to install not only programs, but even updates that the system itself offers. Also I can’t install drivers.

Please tell me how to disable RESTRICTIONS in the FREE system?

Give us an example of what you’re talking about.


Prefix the command with sudo

More information is needed. Example command that you are entering and what output the command produces? What platform, laptop or phone?


There are no restrictions. You have the access to root account. Just use it with sudo.

1 Like

why “sudo” ? the system has a visual KDE user interface. I work through it. and there are restrictions.

more information: I installed the system, the system (for some reason not asking if it was worth looking for updates) automatically found updates when connected to the network. I click “refresh” and I get a “you are not eligible” response. Another example: I’m trying to install the chromium browser from the official repository, and I’m getting an error in response.
(Note: The computer is connected via ethernet and has no network problems, I am writing to you from this computer.)
I didn’t use the command line because I don’t understand it. Everything that I describe happens in the visual interface.
Previously, I tried to use the version with “gnome” and also could not use the official repository in the system.

I can’t install applications from the official repository, I can’t install updates that the system itself found and offered me to install them, answering “you do not have the right”

So if you type sudo apt upgrade in the terminal, it still won’t let you?

1 Like

You can disable blobs RESTRICTIONS, by using Windows OS, or Ubuntu or Linux.
GNU Operating System main Pure Control and Freedom on a dedicated machine. Like L14, Etc.

1 Like

Like UAC on windows this is to reduce the default privileges of the user account for added security by reducing an applications ability to escalate privileges, etc.

The default should be gnome, it’s possible that using KDE broke something with the pureOS store/gnome apps.

Edit: to elaborate, with gnome and the default user it should prompt you for your password not say you don’t have permission.

Though it’s possible sudo is configured in an unexpected way as well and the user isn’t in the wheel group requiring use of root instead of just prompting for the user password.


I strongly advise you to start again and stay with Gnome. Maybe once you have no problems with Gnome, it is up to you to decide to replace working Gnome with KDE.

If you want to use the GUI then you need to capture screenshots (usually PrintScreen or Alt+PrintScreen - or alternatively just photograph the screen) and post them here so that we can see actual error messages.

What hardware are you installing on?


Nothing broke. On the official site, there are 2 official builds of PureOS 10 byzantium: the first with GNOME, the second with KDE. I chose the second one as GNOME is not desktop friendly.
So what should I do to make everything work for me in the visual interface?

That’s a bold statement to make without providing troubleshooting details to back it up, especially with the context of some functionality not working as intended.

I don’t personally prefer GNOME, but I wouldn’t say it’s not desktop friendly. IIRC it’s the most common desktop interface so some people find it desktop friendly. It’s OK to prefer KDE, no need to disparage an option you don’t prefer.

Multiple people replied with ideas and asking for further troubleshooting details, maybe read the whole thread and add those details… when multiple people are trying to help ignoring some of them often results in prolonging the troubleshooting by ignoring a step that would expedite the process and/or getting people to stop helping because they don’t want to waste their time and risk being ignored.

If you just want to be told one thing and have that one thing just work without providing any more details then install some other OS like windows, possibly fedora or kubuntu, that has closer to universal hardware support.


Could the system break or could I break the system if it’s a fresh install of the official distribution + I couldn’t install any software?

Yes, my fault, I did not notice some posts. The form interface is somewhat different from phpBB , so I missed something.

I didn’t find a way to take a screenshot. That’s why I didn’t think of anything better than taking a picture of it with my phone. I apologize for the quality.

The screenshots show a refusal to install updates and a refusal to install the application. The repository is also visible in the picture.

1 Like

The fact is that GNOME is already a problem for me. GNOME doesn’t look like Windows, and that’s the problem.

Hardware “Gigabyte GB-BLPD-5005R” This is an x86 compatible mini computer with UEFI that supports 64bit operating systems.

1 Like

Well, OK, by “once you have no problems with Gnome”, I meant " once you have no technical problems with Gnome" e.g. once you are not getting strange error messages.

I saw in your screenshot “dependency resolution failed”. That basically means that the thing you are trying to install is not compatible with what is already installed. I couldn’t tell what you are trying to install (and I also don’t know what is already installed). If you are trying to install something from the PureOS repository on top of PureOS running Gnome then that is probably a bug and you should bring it to the attention of Purism.

For the other error (Failed to obtain authentication), I don’t think the problem is that you don’t have full rights. I think something is just not working correctly.

No GNOME running. I didn’t reinstall the GUI, I’m not good at it. I did a clean install with a GUI that was included by the manufacturer.
This is the version of PureOs 10 byzantium, from the official site, without any changes.
So… I don’t know what could have gone wrong. How can this be checked?
Regarding the installation: I do not know how to change repositories, so this is the default repository installed by the manufacturer. I tried to download the Chromium browser, it is also visible in the screenshot.
User rights: yes yes, the system is trying to restrict my rights on my own computer and I don’t know why.
There is only 1 user with “administrator” rights in the system, and I’m trying to install updates and download the program by logging in with this account (administrator).
How to check what is the problem and how to fix it?

1 Like

As first please check if your clock is precisely synchronized. Therefore please type in your Terminal application:

$ date

As noted, initial approach (three steps) is already described at the place you started ( what here related:
sudo apt update
sudo apt upgrade --without-new-pkgs
sudo apt full-upgrade

Fourth one would be:
sudo reboot

But this one might (not to promise anything) help there as well:
sudo apt update
sudo apt upgrade plasma-discover

P.S. If above doesn’t work for you and while 1.18.4-2+deb11u1 is somehow strange reference from your here posted photo. Please post here output of:

$ cat /etc/apt/sources.list

My guess is that there is some bug in the KDE image that is not in the Gnome image, because most people use Gnome.

I suggest starting from scratch, starting with Gnome and trying to install something simple that everyone else will be installing. Then see whether you get error messages.

I don’t think so. I think just a bug. The system is not trying to restrict your rights - although that is the end result.

1 Like

It is not about some bug. It is about using PureOS plasma install image from 2022-06-02, therefore what @Gavaudan wrote is still mandatory action:

It is not about some bug (it is about not recently packaged applications date) just while by using today most current PureOS plasma install image from 2022-09-02 might not require any usage of Terminal upgrade commands at all. It is about that @REB understand why things are not working out-of-the-box at this moment (without bringing into subject here UEFI and currently used Intel processor).

1 Like