How to install a working browser?

PureOS browser seems to have some issues. About 50% of the time when I click on a tab, the window closes. I’m not really sure what happened, here but I did have to make a small change to get right-click to work. Not sure if that’s related.

Tried to install Brave browser, added the repo and key but getting 403 Forbidden errors.

Is there a browser that works with switching tabs consistently that will run on PureOS?


  • Craig

it also pastes text from my clipboard in like every other time I click on a text field.

Did you follow this tutorial for installing Brave:

If you followed it to the T is should work no problem.

Vivaldi is another browser I’d recommend, but it is not FOSS, still better than Chrome.

Sure did. Would love to post the output from apt-get, but purism forum is telling me I’m limited to two links. Here’s the first bit:

Err:1 green InRelease
403 Forbidden [IP: 443]

in the meantime, is there a tweak to stop the PureOS browser from sporadically closing tabs when I click on them? It’s super annoying.

I’m relatively new to Linux myself, but a 403 error usually means you failed authentication. (IE: the key is bad.)

I would suggest opening Software & Updates, and removing the repo from the other software tab. Then try to add the repo and key again. See if this fixes the problem.

will give that a try. thanks.

@CraicEm Nope.
As @2disbetter said, you need to follow my version to the letter. Not the original one for Debian.
Remove the file you created in /etc/apt/sources.list.d/ (or as 2disbetter suggested), then do exactly the steps in the HOWTO. Shall work. :slight_smile:
(You have “green” instead of buster, but there may be additional things, so best to just start over)

Hm… assuming you’re not accidentally clicking the close-button, I can only imagine those tabs are crashing. Only tweak would be an update fixing it :wink:

If you are tempted by Vivaldi, please read its privacy policy carefully. It creates a unique ID that gets sent with approximate location information and other data every day. After reading this, I did not bite. :slight_smile:

I stopped using PureBrowser when it was updated last, but it was because of the add-on packages that PureOS requires. They interfered with my Firefox Quantum installation. I never saw the behavior you describe for the browser itself.

If you get interested in Firefox ESR or Quantum, several forum posts describe how to install Firefox, but, unfortunately, not from a repository. Make sure you go through the settings to turn things off. (It might be a good idea to check PureBrowser too, if you get it working.) Some guidance: (For this one, scroll down to Firefox “about:config” tweaks.)


Thanks for the info. I really like Vivaldi for how customizable it is but that is a pretty big no you describe.

I haven’t used Vivaldi for a while now but still good to know.

Sorry man - still broken. Lets see how much I can add here before the forum software scolds me:

root@dekdu:/home/talbert# apt update
Get:1 buster InRelease [2,810 B]
Get:2 buster/main amd64 Packages [642 B]
Hit:3 green InRelease
Fetched 3,452 B in 1s (4,675 B/s)

(appstreamcli:4119): GLib-CRITICAL **: 15:58:27.645: g_variant_builder_end: assertion ‘!GVSB(builder)->uniform_item_types || GVSB(builder)->prev_item_type != NULL || g_variant_type_is_definite (GVSB(builder)->type)’ failed

(appstreamcli:4119): GLib-CRITICAL **: 15:58:27.645: g_variant_new_variant: assertion ‘value != NULL’ failed

(appstreamcli:4119): GLib-ERROR **: 15:58:27.645: g_variant_new_parsed: 11-13:invalid GVariant format string
Trace/breakpoint trap
Reading package lists… Done
E: Problem executing scripts APT::Update::Post-Invoke-Success ‘if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh-cache > /dev/null; fi’
E: Sub-process returned an error code

the closing tabs things - yeah it’s happening I’m not crazy or clicking on the close button. not blind, can see the x on the far right. Clicking way on the other side of the tab, and it just closes randomly maybe 1 out of every 5 times.

Issue with text I copied in to the clipboard pasting automatically in to the next window I click on the almost like an anti-privacy feature.

Now, that issue seems completely unrelated. You successfully installed / fetched the brave repo, and should be able to install brave.
Have a look here:

Then, I’d just run apt update again and apt install brave :slight_smile:

1 Like

ahh… thanks that worked.

Exactly Caliga, that is the libappstream4 issue. Happened with my brand new Librem. Purge it or reinstall it, and that fixes the glitch.

I never knew that about Vivaldi either. Thank you this is great information.