How to install appimage applications with pureos?


#1

Hi
I tried opening an appimage application.
but pureos said mime is missing = or something like that.
how can I install appimage appication with pureos?


#2

https://docs.appimage.org/user-guide/run-appimages.html


#3

Thank yo for the link.
I managed to get one appimage application to work yet another appimage application does not work.
is it possible that one application.appimage works but another app.appimage not working?


#4

It is possible, I had a similar issue when I was running KDE-only PureOS.

A while back I installed a couple AppImages, ran fine. Went to run another and seemingly nothing happened (Balena Etcher). I found that it threw an error when trying to run it from the terminal. If I recall correctly, it was something about being unable to find a file – so maybe a dependency issue of some sort? I ended up giving up and just using dd.

I am now using PureOS with GNOME. Just now, I tried to install Etcher, and it works fine.

I wouldn’t think this should make a difference, but it could. As I understand it, AppImages contain all of the dependencies not commonly found in distros. With Etcher seemingly being a GTK application, it is possible that a KDE-only installation was missing something not included with the Etcher AppImage.

I am not a linux pro by any means, but from what I’ve been able to learn this seems a reasonable root-cause.

Could be worth exploring your exact error and seeing if it leads to missing dependencies.


#5

I’m not an AppImage expert, but yes, I think it would be possible for one AppImage to work and another not work. If the developer of the AppImage builds it incorrectly, then it won’t work :slight_smile:


#6

when running the appimage from terminal i get

sherab@sherab-pc:~$ ./ShuffleStudy-1.4.3-x86_64.AppImage 
installed: X-AppImage-BuildId=97587930-4842-11a9-0af8-17c2a8c48791 image: X-AppImage-BuildId=97587930-4842-11a9-0af8-17c2a8c48791
Segmentation fault

#7

Hmm, that isn’t the most verbose of errors, but I’m going to take a guess at the problem. Given the X-AppImage part, it seems to me like it might be built for the Xorg display protocol and not Wayland, which PureOS uses by default. You could try logging out, and then when logging in again, clicking the gear icon under the username/password field and choose the “Xorg” login option, then try the AppImage again.


#8

A quick search of the interwebs reveals that a segfault with appimage files usually has to do with the appimage itself in some way.

To add to this, I just tried to run the ShuffleStudy AppImage mysef and encountered the same error. Running latest PureOS, fully updated.

I tried the same thing running Debian 10 Buster, fully updated, same error. Both with Wayland and Xorg in GNOME, and Plasma for giggles, too (all in a VM). No dice.

I’d recommend looking to the developer since it seems to be this one AppImage.


#9

Wow
Thanks for your help
Yeah I contacted the developer who was very nice but said he doesn’t have the resources for looking into it.
And so it seems that this will remain the state of affairs with this particular appimage.

The interesting thing is that this appimage does work in Linux mint 19.

Any how thanks for your help
Cheers