How to troubleshoot terrible performance with Manjaro on Livrem 15 v3?

I’ve received my Librem15 v3 at the end of last year. Following my plan I replaced the preinstalled PureOS with the latest Qubes, but within 2 days I figured that it was for now too much of a time investment and learning curve to get it off the ground and I just needed something I can work with, so I installed instead my long time favorite productivity distro Manjaro. It has been running decently except a handful of quirks and glitches, but the performance has always been a bit of a letdown and things have only gotten worse to the point where now it is straight out painful and unworkable.

The most extreme it shows on web browsing. With a reasonable amount of tabs open, clicking on a different tab it may take several seconds until the screen redraws. Even simple pages take upwards of 5 seconds to load, more “demanding” pages (let’s say wordpress post edit page) frequently require half a minute and above! That’s via an USB Gbit ethernet adapter since the Wifi has been unreliable at best. To narrow down the problem I tried loading the same pages on my “old” razer blade stealth 2016, via the same internet connection (connected via wifi though) and it is a difference of day and night.

Overally the GUI feels like on a rather dated machine. Moving and resizing windows is usually choppy. Opening the main menu has such a delay that after pressing the super key I frequently type in the name of the program I want to open in whatever window had focus in that moment.

Loading a webpage commonly sends all 4 cores well into 75% load and more. If I have two browsers open (Firefox and Chromium, god forbid!) the fans of the laptop usually keep spinning noisily until I close chromium, which seems to be especially taxing. Judging from htop, the main load on the system seems to be firefox which is used as the main browser.

I suspect it has something to do with the graphics stack, possibly the driver. I am using kernel 4.19.91 because the 5.4 line gives me frequent gpu crash freezes.

I mostly maxed out this machine because it is supposed to serve as a reliable and speedy native Linux machine for web development that can handle a bit of load if necessary.

Here the essential overview, to have it in one place:
Librem 15 v3
Intel® Core™ i7-6500U CPU @ 2.50GHz
(Intel HD Graphics 520 [i915])
32GB DDR4 RAM 2133 MT/s
Samsung SSD 970 PRO 512GB
Linux 4.19.91-1-MANJARO
3840x2160 monitor connected via HDMI

Generally the UX feels much like on a system that has begun to swap memory, but that is not the case and the RAM not even 20% full. I wasn’t expecting miracles from the laptop, but this is simply unworkable. But since in fact, the performance does not correspond to the specs at all, there is most likely a software issue. Unless one generation later the i7-7500U (my old machine) is supposed to be more than 4 times faster.

I will attempt to run PureOS on the laptop and see if it exhibits similar problems, in which case the hardware might be faulty(?). But it if it doesn’t it would still suck to have to move away from my distribution of choice and redo several days of setup work. Kind of defeats the idea of “Install what you want” (I also wanted to have Windows 7 on a separate drive at some point, but no deal with coreboot, different story for a different thread)

If someone has advice what I could do to diagnose and potentially solve this problem I would be most thankful.

Just a suggestion. Is you disk trimmed?
sudo fstrim --fstab --verbose
increased performance dramatically on my Fedora system with SSD.

oh wow, trimmed 10GB off root and it certainly feels like it makes a huge difference! Still not totally satisfying performance but at least now it is usable. Thank you very much! Have you got some more tips with similar impact? :wink:

1 Like

Great input! It’s funny the things you can miss, and I managed to miss TRIM on SSDs.

I just bought my first SSD for use on a Linux system, a 500 GB Samsung in a SATA Notebook form factor package, but I haven’t installed it yet. I just did a search to see if TRIM was affected by SATA vs. NVMe and the only hit I got tried to hijack Firefox and phish me with some stupid prize.

What kind of SSD are you using on your Fedora system? Do you know if TRIM applies to both sorts?

It took me a long time to figure out why my system was so slow. The slowness was most apparent while starting Signal desktop or doing a “dnf update”. Here are a few links from my bookmarks that I made when learning about TRIM on SSDs (note that some info is outdated):

I do not know about differences between SATA vs NVMe, but I guess that TRIM will be applicable to all types of solid state disks.

fstrim will be enabled by default in the next Fedora release:

This is info about the SSD I use in my laptop:
Drives: Local Storage: total: 223.57 GiB used: 194.68 GiB (87.1%)
ID-1: /dev/sda vendor: Crucial model: CT240M500SSD3 size: 223.57 GiB

I have a 13v3 running Manjaro stable Gnome for a year and a half. I have not noticed any issues have been really happy with the performance. The Manjaro forums are great. I am not sure where to start looking for your issues but I would ask the Manjaro community