How to type accented characters such as é, ü and è in PureOS?

I’m trying to type accents on characters, but I"m having a hard time with that. I’ve set my keyboard to

English (International, dead keys with AltGr)

I tried doing the right Alt key + the single quote, but that gives me nothing. I tried many other variations, but nothing seems to work.

Could anybody enlighten me an easier method than googling for those letters and then copy-pasting them?

1 Like

Maybe check out Compose Key. You find the setting in Tweaks… Keyboard & Mouse.
You can find more info in the help menu under Tips & tricks… Enter special characters


@superpure The chart I’ve been needing for 3 months. Thanks!

1 Like

Personally I switch to the keyboard in the language I need, which would probably be the French one in your case.

Once you’ve added more than one keyboard in the PureOS settings, you can toggle quickly between the keyboards with <Purism key>-space.

I don’t know how familiar or not you are with “dead keys”, but the way they work is that you type the accent first, and then the vowel (the fact that in your case you use the AltGr key to do that adds an additional step/layer of complexity… AltGr+dead_key, then release AltGr, then type the vowel… all without seeing the accent before it is fully formed).

Please specify which language you’re interested in, because it’s quite likely that there might be a particular keyboard layout better suited to your usecases. The German and “French (Canada)” keyboard layouts are examples of such layouts that allow typing dead keys accents without the AltGr key. Some other layouts allow typing accented letters directly (without dead keys at all), with less flexibility. So it really depends what your needs are, how far you’re willing to deviate from the English QWERTY or Dvorak, etc.

1 Like

I just use the unicode… for example to type the ñ character, I first press ctrl-shift-u, then I type 00f1, then the spacebar, and the ñ is entered.

1 Like