How to update a new Librem 14?

I tried to update a brand new Librem 14 and ended up with an unbootable system. I have another one now and I’d like to update it. What is the proper procedure to get everything totally up to date? I’m familiar with Linux.

You mean besides sudo apt update && sudo apt full-upgrade ?

That’s what I did the first time but when I reported the unbootable problem I was told I should not have done full-upgrade:

I’ve run apt update and apt upgrade. After apt upgrade it says 14 packages are being “kept back” including pureos-standard. How can I get those packages upgraded?

Once apt upgrade is done, should I only do updates through the Gnome “Software” utility?

Should I really avoid apt full-upgrade?

Apt upgrade will not install new software. Your packages are being held back because they need new dependencies. Full-upgrade will install them. I’ve never had a problem personally with full-upgrade, but I’ve never used PureOS and I’ve been on arch-based distros for a while now.

You can use gnome software instead, but I myself don’t know how that would be different aside from updating flatpaks (which apt won’t do). If you’re in doubt, make a backup first.

1 Like

I recently had packages are being “kept back” on my Librem 14 and I sorted them out with the following commands:

sudo apt-get -f install

sudo apt-get -u dist-upgrade

By the way, I have never used the sudo apt full-upgrade, so cannot comment on that command.

I use the commands @Gavaudan suggested on the command line in PureOS all the time, i.e. with “full-upgrade”. I have not had an issue. I never use Gnome Software.

Even though you are not upgrading releases, you may want to look at the list of packages being held and why. It might give you and the folks here an idea. There must be some dependency holding things up. Maybe it is that annoying -dev package for gcc discussed elsewhere. :slight_smile:

I went ahead with full-upgrade and all is well and seemingly up to date. It sounds like I can either use apt or the Gnome software to update things from here on out.

1 Like

I would suggest turning off auto-update in Gnome Software. If Gnome Software tries updating while you are manually updating in the Terminal it could cause issues. I turned off auto-update in Gnome Software and in the Software and Updates application. I update using Terminal. Then I reboot. Then I go into the Software application and check for updates to update the Flatpak packages.

This was suggested to me elsewhere on this forum. In my experience, this has been the smoothest way to update my system.