How to update/upgrade Librem5

How do I update/upgrade my Librem5 phone. I haven’t messed with this phone in months since I was quite disappointed with it when I received it. Basically it’s just an expensive paperweight right now and I was thinking of trying to get it updated with latest software to see if it would be usable.

The problems that I have with it are not limited to these:

I believe it is missing important basic functions that your how-to guides show that I should have.
I cannot get it to operate on LTE (using either Straight Talk (ATT) and Pure Talk (ATT)).
The battery doesn’t last very long, even when the phone is turned off. I have android devices that can go weeks or more while being turned on, and months while being turned off.

I’m sure if I actually used it there would be more issues with it, but for now it is useless, which is why I was wanting to try updating it.

Any help would be appreciated, thanks.

You start the phone, connect to the Internet, open the “PureOS Store” app, go to the “Updates” tab in the top and press the little button in the upper left corner, the one that looks like a circle with an arrow head on it. Let it search for updates for a while, then click the blue button that says “Restart phone”.

It’s in the booklet you get with your L5, if I’m not mistaken.

And yes, there have been a lot of improvements in the last couple of months. However, if you’re going to compare it with an Android device (> 15 years of development by one of the biggest and richest tech companies in the world who has poured billions of dollars and countless man hours into making it what it is now as opposed to the small Purism team that has worked on this for only a couple of years), you’re going to set yourself up for disappointment.

You can mail support. They have updated firmware for your modem that will enable VoLTE. Made a world of difference in my case. The reason Purism does not ship it by default, IIRC, is that it still might cause some problems for some people.

I understand android has many years of development behind it. If the battery dies (0%) after a number of days when the phone is powered off then the phone is not really powered off. Does the updated software fix this issue? To me this seems to be a hardware issue, not a software/development issue.

install the package: bm818-tools and use it to check if VoLTE is enabled on your phone.

I get some sort of error. Part of it is off the screen so I cannot see the whole thing. Certificate verification failed… certificate chain uses expired certificate… Could not… in the certificate verification. [IP].

The error notification is on the top of the screen and won’t go away. I cannot click anywhere to get it to hide or go away.

I was able to close the update program (by swiping it away) and the error went away. But comes back again when I try to download the updates.

Lowered the display from 200% to 100% and now I can see the whole error, although the text is so small I can barely read it.

Unable to download updates:
E: arm64 libgnutls30 arm64 3.7.1-5+deb11u1 is not (yet) available (404 Not Found [IP:])

Is your system time set correctly? It sounds like it thinks you’re time is before the update is due to be released.

I thought about that too, the time was off. I adjusted the time and reran the update check and got the same thing.

Can you get a command line running? If so, try:
sudo apt update && sudo apt upgrade

If that doesn’t work, post the feedback here. Maybe it offers some more clues.

Last I read, AT&T does not approve the L5’s BM818-A1 modem for activation or continuing service.

T-mobile does, as well as any MVNO that uses T-mobile’s network for service.

Well, this should always be Job One with electronics. :wink:

That worked. Although now when I go to the update page in the GUI it says ‘Up To Date’ ‘Last checked: 1 year ago.’

And now, whenever I unlock it, after I put in the passcode, it pops up with a USBGuard action needs authorization, and I put it the passcode and the popup goes away and immediately comes back then I put the code in again and it goes away.

I am in Alaska, so it is either ATT or Verizon.

That’s unfortunate. Those are the two carriers with the most restrictive BYOD policies. It’s odd that the BM818-A1 modem, which is used in automotive systems, isn’t approved.

If you’re unable to get service through either of those, and if T-mobile has nil coverage there, you may have to consider a data-SIM-plus-SIP-or-XMPP solution instead.

EDIT: BTW, is your L5 updated to the byzantium PureOS repo, or still on amber? You can check this in the PureOS Software app, in the preferences.

I see three repos for Byzantium toggled on but it says 0 applications installed in each. On the main update page it says “Up to Date” “Last checked: Just now”

1 Like