How to use diacritic symbols the 'dutch' way on Librem 14 US keyboard or customize keyboard in PureOS?

Any dutchies here who encounter a similar problem, and solved it?
Or belgians?

Since yesterday I am the proud owner of a Librem 14 with a US keyboard, qwerty.
Everything is basically the same, but one problem occurs while writing: I cannot figure out how to type accent marks like umlaut, acute accent, grave accent etc without using codes/ALT. (Since I use them a lot, this is quite inconvenient.)
Normally, to write é on a dutch style keyboard, you just type ’ and e.
When you want to write ë, you write " and e.
When you just want to use ’ or ", you type ’ or " but it only occurs after you press spacebar.

Any suggestions how to achieve this with my US keyboard on PureOS? I can’t change the language in keyboardsettings to Dutch. I can change the layout to Dutch however, but that doesn’t make any difference.
Any packages I can install, any way to customize my keyboard, software from PureOs store…?

Since I live in Belgium I’m also familiar with azerty, so I’m quite flexibel when it comes to the possible solutions. As long as there is a quicker way to use these accent marks.

I’m in the U.S., and sometimes need international letters. My workaround for Linux Mint MATE is a panel applet called Character Palette, which I place in its own panel (i.e. taskbar), and display on one side of the screen. Then when I need a diacritic, I grab it from there.

This doesn’t exist in PureOS, as far as I know, but maybe it’s possible to add some kind of shortcut to a similar app, like the one named 'Character Map`. Not ideal, I know.

Edit: Maybe this will help:

Did you try to enable and define the Compose function? With that, you can type Compose e ’ and end up with é

(This of course is not the same as just typing ’ e but that behavior would drive me nuts, given the amount of coding, using ’ and ", that I do.)

I have Compose set as right-alt (and use left-alt as the actual Alt key).

I used the gnome-tweaks command to enable and define the Compose function.


Log in to the terminal as “root”.
Make sure the ‘locales’ package is installed:
dpkg-query -l ‘locales’
If not then
apt-get update
apt-get install locales
If installed then
dpkg-reconfigure locales
Select the desired locales. Then add the necessary layouts to the keyboard.


No haven’t tried that yet, thanks, will try!

update: this is already a big help. I wasn’t aware yet of the compose function.

I’ll try that too, thanks a lot!