I cannot update snapd and therefore cannot install from snapstore

I tried to install zoom-client on my librem 14 form the snap store and have received this error:

asclepius@librem14-blacktop:~$ sudo snap install zoom-client
[sudo] password for asclepius:
error: cannot perform the following tasks:

  • Mount snap “core22” (1122) (snap “core22” assumes unsupported features: snapd2.55.5 (try to update snapd and refresh the core snap))

I tried sudo apt update && sudo apt full-upgrade. I looked at the “other files” in the upgrade app and deleted two earlier problematic pureos repos then rebooted. I have had zoom on my librem 14 before. I since put windows on it and now have wiped it with a fresh pureos install. I am at a loss for how to update snapd.

Snapp version query gives:

asclepius@librem14-blacktop:~$ snap --version
snap 2.49-1+deb11u2
snapd 2.49-1+deb11u2
series 16
pureos 10
kernel 5.10.0-28-amd64

I am also unable to update it to the latest version (2.55) and cannot install the snap-store either because of this.

Any ideas?

Thanks for taking the time to look at this.

1 Like


sudo nano /etc/apt/sources.list
and replace the word byzantium with crimson and save.

then do

sudo apt update
sudo apt upgrade --without-new-pkgs
sudo apt full-upgrade
then restart your system

this will upgrade your system to the latest pureos version which called crimson, the one you are using currently called byzantium.

This will give you snapd version 2.57.6


Additional data point: The current LTS version of Ubuntu, which is almost 2 years old and almost ready to be replaced by the next LTS version, provides snapd 2.61.2 so even crimson is somewhat behind.

There may be some risks with upgrading to crimson in the sense that I think it hasn’t been released by Purism yet (for the Librem 14). Is it ready for primetime? As such … imaging the disk might be Step 0 before doing sudo nano ...

Another random option might be running Ubuntu in a VM inside PureOS.

1 Like

Thank you. I ran that command and opened nano but it only says GNU nano 5.4 and no sources are listed.

How do I get the sources back?

1 Like

what does this command give you ?

ls -l /etc/apt

1 Like

I thought they moved librem 14 to crimson, so librem 11 has crimson but not librem 14

1 Like

@Asclepius if the above is true then upgrading to crimson may not be a good idea unless you are willing to take the risk.

1 Like


I think the Librem 11 has crimson (because it has essential requirements for certain more recent software, being more recent hardware).

As I said, imaging the disk … mitigates the risk. :wink:

1 Like

This may sound strange, but snapd is offered as a snap (version 2.61.2). I would try to do a:

   sudo snap install snapd

I would then stop the snapd daemon, uninstall the non-snap version of snapd, and start the snapd back:

   sudo systemctl stop snapd
   sudo apt-get remove snapd
   sudo systemctl start snapd

If that fails you can always reverse this and reinstall the non-snap version of snapd.

1 Like

Maybe this is slightly off topic, but I think if I got to the point of feeling pressured to use snaps on my Librem 14, I would probably consider going back to Ubuntu or Windows. If we do internet traffic monitoring, the snap systems are always constantly pinging their home server from your device once you have that stuff. So, similar to Windows update, you’re always reporting to that service all the time while the device is on – supposedly checking for updates, but in my experience checking way more often than when a human actually humanly needs updates.

A package manager like apt that updates when I issue an update command, or that maybe notifies me about updates on boot, is more my style because it puts me in control. Some folks might disagree, saying that it’s inhuman to keep up to date with how many security vulnerabilities we have these days, so use of a PC should essentially be like a live service. I can get why they end up thinking that way, but I’m just tired of being mistreated by large corporations so personally I was going it alone recently (as much as I could manage). And so I’m not going to install snap anything on my Librem 14.

Anyway, it sounds like others gave you some good tips, though. Good luck.

1 Like

You can read the source and see exactly what snapd is doing. So, in the sense of knowing what is going on, it’s not at all similar to “Windows update” since I can’t seem to find the source for Windows. :wink:

Or, you know, you could read the documentation and find out that this is configurable. Some configurations are only for v2.58+, but changing the timing has always been an option. By default it’s 4 times a day. You can change it if you wish (snap set refresh system.timer= … with options documented here https://snapcraft.io/docs/managing-updates ). On recent snapd (2.58+), you can even do a “snap refresh --hold” to stop auto-updates and only update manually.

And so I’m not going to install snap anything on my Librem 14.

Your choice. But since you don’t seem to know some of the control/settings, you might want to read the documentation to make sure your assumptions are correct.

Frankly, I only use snap for things like lxd, chromium and, occasionally, for getting a more recent version of software (e.g. I use the LTS releases for 4 years. There is almost always a feature/fix in ffmpeg that I need. A “snap install ffmpeg” is a lot easier than compiling myself … which is what I used to do.).

I suppose if I were using proprietary software like teamviewer, zoom (like OP), or spotify … I would probably use the snap there too. But I don’t.

For PureOS users, I should note that, presumably, the snap confinement is like it is on Debian. That misses one of the patches that Canonical has not been able to get into kernel.org. Specifically, I don’t think that any of the confinement rules for AF_UNIX (socket IPC) should be counted on. This should not be a huge issue, but people should be aware of it.


I changed the repos to crimson in the other software section of the update manager. Then I did sudo full-upgrade --without-new-pkgs. It was in the process of an hours long update. Then I read the warnings about crimson and Librem 14 and closed the terminal. I assumed it was just downloading packages at that time. Then I couldn’t add the byzantium repos back. So given that there is nothing on the machine that isn’t backed up, I went for a clean Byzantum install from USB. After that I couldn’t execute sudo apt update. It was unable to lock onto somehting.

Problem solved/avoided by just installing Mint. I like that better anyway as my printer worked out of the box too.