I don't Know What ^@^@^@^@^@ Means

I used the ckick Power Off and it half shutdown.
The screen is not black, but a dark grey instead and at very top left are the text characters “^@^@^@^@^@”. They are so small I used 2 magnifying glasses to see what the characters are.

I held the power button down and it eventually shut down taking with it those characters and turning screen back to black.

My point is, that after seeing screen closed, I put the phone away not realizing that it was still in a twilight zoned state of shut-something.

Can I repeat the problem? Nope - phone wouldn’t start. Held power button in for a while, blue light comes on, then neat blue starts flashing and back to nothing. I can repeat the restart to blue flash to Neverland. But, the old yank out the battery, restart - worked.
This after a successful flash.

Oh, almost forgot. No more problem with SMS or MMS. According to the L5, there is no network manager now, another repeat error to ‘contact software management’, and checking, it had dropped in to airplane mode. That AI seems to think I need to do but needs serious Intervention. It took a while to get back and off the flight I wasn’t on.
As someone else here said, ‘What a train wreck’.

I’ve named the phone Murphy.
Kewl eh!




Traditionally, ^ before a character means “control”, in the sense of the “Ctrl” key on a physical keyboard. So if I write “A” then it means the letter A but if I write “^A” it (ambiguously) means the control character “Control A” (ASCII value 01), which may or may not actually do anything when pressed. By extension, “Control @” gives ASCII value 00 i.e. the NUL character. You can see that notation at work in, for example, vi (but you need to use Ctrl/V to insert a control character literally into a file being edited by vi when in insert mode).

Things are more complicated these days anyway with GUI applications because “Control letter” may be interpreted not by the keyboard but by the application - and of course keyboards may be on-screen, not physical.

So I guess you either typed 5 NUL characters (unlikely?) or something wanted to display 5 NUL characters - and in either case something displayed that using the notation discussed above.


Definitely not I. And no no one has been near it. This cannot be blamed on user. The phone isn’t as smart as the ads say it is.

  1. List item Swiped up to close calculator…

  2. List item Swiped down to get to “Notifications” screen.

  3. List item Tapped Power

  4. List item Tapped Power Off

  5. List item Screen Went to dark grey and those characters appeared in extra, super duper new and improved micro fonts.

Today this is by far the most safe and secure privacy respecting device on the planet. So private that even I can’t get in to it!

Details in new Post.
Has sure taught me some new cuss words though.


The characters are small because it’s the native font size (100% magnification) and is AFAIK outside the scope of fractional scaling of the user interface.

I may be wrong here (story of my life), but I have seen this occur several times while tinkering within the OS to try to squeeze out more performance and generally associate these artifacts with a memory fault or some other form of “hard stop.” I’m hesitant to state a kernel panic, as I haven’t seen an error message specifically stating that it’s a kernel panic, but it’s possible that these characters are synonymous.

The way I have most reliably produced this is by the following:

  1. Create and enable a swapfile on the micro SD (not a good idea in general, but bear with me)
    • may potentially occur with a swap partition as well, but I have not tested this
  2. Enable suspend
  3. Use a memory-intensive program (WayDroid) on the phone, which would start consuming swap space on the standard L5 with 3GB of memory
  4. Wait for suspend
  5. Wake up device
  6. See control characters
    • the only reaction is to forcefully turn off via a long press of the power button

It seems to me that what happens is that swap space is not immediately mounted/re-enabled upon waking, thus causing a memory fault (trying to read from memory which is not available), which freezes the phone and displays the sequence of control characters on the screen.


So. Do I set the microwave at low, medium or high to thaw that ‘freeze’ out of it?
Come on. I know it doesn’t work. I know this phone is either lemon-made, haunted, infected, or possessed. Too, I’m not a phone engineer, phone hobbyist, or Linux Kahuna and never expected to have to become all of the above.

Following that rash of ^@ microcodes, is today’s adventure through Gehenna. The whole (censored) day trying to get apps to appear instead of a hour long Kiddie-Koded-Blue-Background. KKBB.
Reading and more reading to no avail until I found they hide behind the KKBB.
Too, this morning, there was no, has been no, can no matter the settings, still no WiFi. What the … Gehenna!

At the end of the day, I learned that I must swiped the KKBB upo to see the opende app. Was hiding there the whole, time.

For other victims:

1 - Turn phone on and get by the unlock screen.
2 - If you are presented with the KKBB instead of the desktop, - swipe up.
3 - Voila! That desktop was hidden by the KKBB.

Do the same when you tap any app and get the KKBB, just swipe up and you’ll find the app is open behind the KKBB.

This is not a “smartphone”. It is as smart as a sack of hammer and in dire need of professional intervention.



I think that yours is in need of professional help🙂