I managed to softlock my Librem 5

I was trying to install anbox on the Librem 5, didn’t work out as the morphis dir doesn’t have a master branch, so updating that is disabled by default, which led to me trying to install the anbox kernels manually, which didn’t work out either as the directories aren’t the same between pureOS and whatever OS the instructions were for.
Anyways, here’s how I softlocked my phone: I tried deleting the zip file for the two kernels, which is more or less impossible to do unless you have the phone linked up to a PC, as releasing your finger from the file makes the additional file options disappear. I tried deleting the file for a handful of minutes, and voila, the file icon now teleports to wherever I click, as if I’m trying to drag the file, even if I’m not. I tried shutting the phone down to see if it disappears, but now I can’t really get past “cryptsetup: crypt_root:set up successfully” (as I don’t have a nano SIM card yet, I get that screen every time), as the screen just goes blank black screen after a couple minutes of showing that the cryptsetup worked.
Really wish there was an easy way to factory reset the phone, because I don’t have pureOS installed on my VirtualBox on my laptop.
Edit 1:
I do have a 64-bit Debian installed, but when following the flash reset instructions, I can’t get “uuu” installed because the package unable to be located.
Edit 2:
I tried installing snap on my Debian VM, and getting uuu that way (am assuming uuu is universal update utility) but it didn’t help.
I have no clue what causes me to get

Note, using directory '.' to get the build dependencies
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 builddeps:. : Depends: debhelper-compat (= 13)
E: Unable to correct problems, you have held broken packages.

when running sudo apt build-dep .
Edit 3:
I needed to install the python3 packages tqmd, yaml, and jenkins before I could do the final step. (Sorry for being so noob XD)
Edit 4:
I am now getting spammed by windows not recognizing the phone and thus disconnecting and reconnecting it over and over again. No clue how to actually flash my phone now :confused:
Edit 5:
Clicking the phone “USB” made it so the flashing went forward, but it adamantly refuses to recognize Snap’s universal update utility, so I can’t actually flash because I don’t have uuu installed, and I have no clue how to install it.
Edit 6:
Updated my debian distro from Buster (10) to Bullseye (11), whereupon I could finally install uuu
Edit 7:
Pretty sure that because my windows is constantly unplugging and replugging the phone, I can’t finish resetting it, because I keep getting

Edit 8:
I literally cannot get past this stage due to the device gettind disconnected and reconnected by windows or smt during the installation of files. Best I’ve gotten so far is 0 Succeeded, 1 Failed during install.
Really need help here.
Edit 9:
I should add that I’ve done all this with the USB-C to USB-C cable that came with the phone, will try with a different kinda cable tomorrow.


i do not have my Librem 5 already. So i have no experience with the Flash Mode.

But without the uuu Package on your Debian (in a VM?) i would suggest to set up a PureOS Live-USB Stick. Boot your Notebook or Desktop via Live-USB from your USB-Stick and run the Reflashing Firmware Process from there.


Take Care, you will lose all your Data on that USB-Stick you will using for a Live-USB. So have a Backup if you need one.

OK, you installed uuu already but still use a VM?
Did you noticed on the Top Left of the Picture the Issue about “Failed to attache the USB Device” … “to the Virtual Machine” …?
If you can and now, how to boot from a Liveusb, i would suggest this way to https://forums.puri.sm/t/new-post-reflashing-the-librem-5/11867

Good Luck and hope i did not miss something important.

Thank you for the tips, although sadly I have no clue what to do when my VM fails to connect to the USB device after it’s been disconnected 2 times during the reflashing, while also changing names. :confused:

@Atryx10 uuu is also available for windows and can be run there.
and you should be able to run the flash script for the librem5 with bash that you could install with git which you also need for the script.
There might be some path Problem depending on where you put the uuu.exe but that should be solvable.
That way you should be able to get around the reconnecting usb port for flashing the librem5.
And you’ll never need to install jenkins to the Librem5 that is an Continuous Integration(CI) tool used to build packages on servers like purism is using to build their packages.

Okay, good to know! I should add tho that I’ve done all this with the USB-C to USB-C cable that came with the phone. Will try with a different kind tomorrow.

Sorry for the late reply, life got in the way!

I managed to get the phone working again.

I had to use diskpart to fix the usb so I could use etcher to flash a more up to date version of pureOS (that I was given by one of the people working at purism) to the usb.

I then had to do the following in diskpart to get the usb fixed:

DISKPART> select disk 2

Disk 2 is now the selected disk.

DISKPART> convert gpt

DiskPart successfully converted the selected disk to GPT format.

DISKPART> create partition primary

DiskPart succeeded in creating the specified partition.

DISKPART> format quick fs=ntfs

  100 percent completed

DiskPart successfully formatted the volume.

After that, I booted the pc from the USB, and I had to install git, uuu, and I did a sudo apt update just to be safe in the live version of pureOS.

Then I cloned the librem5 git, installed the udev thing, and then finally it was just smooth sailing with installing the phone using the instructions given.

1 Like