I tried to install PureOS and destroyed my computer

Yo guys, A few days ago, I tried to install PureOS on my HP computer with Windows 10. It obviously failed, but the point is that my PC doesn’t boot now. So I wrote a Lubuntu bootable USB to enter into the terminal to run the boot repair tool, but nothing happened. I decided to reset it in factory settings, but I could not enter recovery mode by pressing f11. Maybe I have destroyed my HP drivers or hard disk! I hope it’s not the second.

  • Intel(R) Core™ i3-2100 CPU @ 3.10GHz

Welcome to the Purism community; note that this forum is not for customer support, but I will provide you some basic steps to diagnose your issues.

  • It sounds like you have a second working device as a backup, so create a live Debian image on a USB drive instead of PureOS using a tool such as balenaEtcher: Debian is more widely compatible. If you have another Windows device instead, Rufus is also a similar tool to consider.
  • You need to be able to either change your boot order so that you can initialize the USB drive for a boot drive. If you can do that, then you should be able to reinstall any operating system.

You chosen a fancy username. :wink:
Why installing GNU OS on a non-Gnu Computer? so you need to install the cheaper Linux OS.

I said that I wrote a bootable Lubuntu USB and tried to run Boot Repair. If you want more information about the error, it asks me if LegacyWindows detected it. The boot of your PC is in EFI mode. You may want to retry after changing it to BIOS-compatibility/CSM/Legacy mode.
Are you sure you want to continue anyway? I press yes, and then (grub2 purge is cancelled). Also, when I try to install Lubuntu, it gives me an error: "T bootloader could not be installed. The installation command

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=ubuntu --force
returned error code 1.

The conclusion from an AI: Based on the information provided by Boot Repair, it appears that your system is currently set up in UEFI (EFI) boot mode. However, there is a discrepancy in the boot configuration. Ubuntu is installed in legacy BIOS mode on sda5, while Windows is installed in UEFI mode on sda1. This mismatch can cause boot issues.

I have done everything, and for this, I decided to reset my computer to factory settings, but the drives don’t work when pressing F11.

As for why I downloaded it: I didn’t know

It weird that is not working F11 as the BIOS it in separated chipset. Unplug the SSD and try again f11.

Are you pressing F11 to enter the BIOS/UEFI or are you pressing F11 to do a factory restore?

It is possible that you deleted the partition on your HDD/SSD with the factory restore, so you can use it to reinstall your system.

PureOS doesn’t work with UEFI, and PureOS isn’t a good distro for you if you need blobs to run things like the WiFi/Bluetooth (which is 99% of the computers today).

My recommendation is to boot into your BIOS and make sure that you are using UEFI and not something like ‘legacy mode’ or ‘BIOS mode’ or ‘legacy BIOS’. Then try to do the factory restore again.

If that doesn´t work, then try to boot up the machine using a Live DVD or Live USB pen drive. Make sure in the BIOS that you have set the boot order to first boot from the DVD or USB port. Also, if you have another machine, try out your Live DVD or Live USB to make sure that it is boots on the other machine. (I have had problems creating Live USB drives that were bootable,) Then when you do the installation, I recommend deleting the existing partitions so you will only have one OS on the HDD/SSD, because multi-booting complicates things.

1 Like

I am not interested in helping you if you are making drastic decisions without a clear goal.

Anyway, after 5 days, it was more easy than I imagined. I just pressed ‘‘Delete the disks and install Lubuntu’’. Thanks guys

1 Like

Sure, it is up to you if you want to continue reinstalling PureOS without an explicit purpose.

The second answer is somewhat exaggerated, so there is always a purpose, and that is safety

Feel free to reinstall PureOS for whatever safety purposes; hopefully it does not “destroy your computer” this time.

Yeah, I feel free since I read your topic about Purism’s Guide to Security and bought all the products

1 Like

I am glad you feel more free after doing so: after all, that is the point of gratis and libre open-source software.

1 Like

So we are all happy. :blush:


Mr Grubgrub,

I saw your topic today and I wanted to make a comment about “safety.” This week for the first time, I decided to try installing PureOS on my Windows 10 laptop too. In order to stay safe from any damage to windows, I did the following:

  • Powered off the device
  • Removed the battery
  • Removed the hard drive via the side slot (for safe keeping of intact windows)
  • Inserted a hard drive with an intact AlmaLinux install
  • Used the AlmaLinux to burn PureOS iso installer to flashdrive using command line “dd” command and no additional third party programs
  • Removed the AlmaLinux hard drive
  • Inserted the hard drive where I wanted to install PureOS
  • Attempted to boot the flash drive
  • Edited some BIOS setting to disable UEFI on flashdrives
  • Attempted to boot the flash drive again, this time succeeding
  • Clicked the menu option to install PureOS
  • Used the installer application inside of what booted
  • Booted into my working PureOS install for the first time
  • Realized that as others have said, WiFi was the only thing not working
  • Inserted a different flash drive with a Debian version of nonfree wifi drivers so my machine could use the internet
  • Installed the nonfree wifi drivers from the flash drive, tainting my computer (Because free software puts the user in charge but that means I can make dumb bad decisions if I want to!!)
  • Proceeded to have a fully functional PureOS(+debian taint) laptop setup

In this case, what kept me “safe” from losing anything or any problems was the “hard drive slot” hardware. Not software. And so I found my first installation of PureOS on a laptop to be easy and effective.

It sounds like you might be using a hardware that does not have the “hard drive slot,” which is seemingly an antifeature and bad purchasing decision on your part. Please do not hold your decisions to buy bad hardware against people like PureOS devs who believe something is wrong with the trajectory of technology today and want to try to take control and build a different possibly better future via their technology understanding.

Your solution to your problems appears to be surrender to your lack of understanding instead of an increase in understanding. This is perhaps best exemplified by the idea that you would put your operating system decisions in the hand of the budding field of today’s generative AI. From my perspective, such tools resemble a parrot. I can go to the zoo and see a parrot speak English. That creature has fantastic neural networks inside its bird brain, the nature of which I do not truly understand. But I would not lay out my hard drive before the parrot and ask it to be the oracle of my operating system technology problems, even despite its fascinating ability to speak English to me.

With all of this in mind, the feeling you exude that people who want a different technology future have failed you or created something that simply doesn’t work – because you did not invest the time to understand it – is somehow saddening to me as another fellow user of libre tech. Once you surrender to the unwillingness to understand the technology, nothing anyone could advise you about staying safe is remotely applicable because you are deciding not to want to know. It means that to stay “safe” you should use a Mac or Windows or Android device with everything pre-configured and automatically updated because you don’t want to know how it works. And that ends up different than the entire concept of libre software because libre software comes at it from the angle of believing everyone should know and be willing and able to know how it works, even though sometimes we don’t.

And then, ideally, we do not put the blame for erasing the Windows recovery partition on any particular operating system distribution. We put it on the user. Because the user is allowed to decide what to do.


Piece of constructive feedback for @grubgrub - and I see this all the time on YouTube and other forums as well.

Your issue was due to a clear lack of technical skill. If you come to a forum claimed a certain piece of software destroyed your computer, you will attract immediate antipathy. Only in the rarest of the circumstances, a piece of software will literally destroy your computer - think of it as damaged beyond repair. I can think of a firmware flash gone really bad, for example. A software installation going wrong will NEVER destroy a hard disk.

Sometimes I am on youtube and I post a video about something. Someone asks “how do I do this”. You give some general guidelines, as it is clear that the person has not “googled it” or even bothered to provide some detail about what has been tried. Then the message that comes afterwards is the classic “but I want to know how to do it!”.

Some pro tips on asking a community for help:

  1. Don’t claim a product people care about and know well destroyed your property or life.
  2. Provide at least some clarity on what you’ve done up to the point you got stuck.
  3. Describe what you have already tried to do to solve the issue.

You got 3 right, but not 1 or 2.

And this kind of topic title really gets on my nerves. It’s basically the “SOE optimized clickbaity” version a forum post. Other variations on such:

  • A or B is a scam.
  • Whatever component/product is broken!
    and etc…

I find it very odd that “Solved by” is a refusal to solve anything.

1 Like

Without an objective, one cannot make suggestions toward solving anything.