I'm unable to use USB's to install an OS


Everytime I try to install an OS through a bootable USB I get the following errors:

!!! Could not find any iso
+++ Scanning for unsigned boot options
!!! Something failed during USB boot
!!! Starting recovery shell

I’m not sure what I did to cause this it was working previously fine, or how to fix it. I’ve tried multiple USBs, formatted my NVMe and unplugged my battery to reset settings. Help would be greatly appreciated.

Trying to mount any USB to /media also fails with:

mount: mounting /usb/name on /media failed: Invalid argument

Are you using a thumb drive formatted with exFAT? Make sure it’s formatted with FAT32 if it is.

I will give it a try! Thanks for your reply!

Edit: It gave a tone of errors when trying to boot off the USB, I was unable to catch them, but it appeared to be booting into PureOS live boot.

It then seems to error repeatedly:

/init: line 44: can’t open /dev/sdb: no media found

And then opens the initramfs

Trying with a different USB that I know can boot, it throws these errors:

!!! could not find any iso, trying bootable usb
+++ scanning for unsigned boot options
failed to parse any boot options
!!! something failed during usb boot

I ended up managing to install PureOS after checking that the checksums where fine (so it was a bad usb install).

Haven’t tried Quebes yet.