Initial Librem5/Nexdock360 impression

I did not write to them, yet. My concern was, that the matter is too much an issue aside both for Purism and NexDock and i did not want to pull more of the precious developer cycles than absolutely necessary.

I’m currently not working with the NexDock, but if you are interested, we can try to write down our findings and i would test the cases again. I think my biggest concern were:

  • prevent burn-in of the internal screen on the Librem5 when docked.
  • prevent burn-in of the NexDock screen, when not used.
  • keeping the NexDock loading the Librem5 when connected to a power supply.
  • a more pleasing procedure for the device pair when going into suspend (no white alert screen)
  • a better wake up procedure for the NexDock/Librem5 pair

The first point should apply to other scenarios, too, e.g. when the Librem5 is docked to an external screen. There is no option to blank (or switch off) the internal screen when the device is docked and the external screen is primary.

The second point is realized, as good as i remember, by NexDock already, though in a somewhat unpleasing way. When switched off by the Librem5 the screen turns white (not black) and the NexDock waits a while until it decides that the Librem5 does not come back. I did not find anything the NexDock’s menu to customize the behavior. That would be something to adjust from NexDock’s side.

I have not really tested the third point. I.e. does the NexDock still provide power to the Librem5 when it enters its switched-off mode? My impression was no, but perhaps it does. It should do, if the NexDock is itself connected to the Librem5 as the NexDock then either forwards the power from the supply or words a power bank. But does it?

Ideally, in this mode, it should also still forward keypresses or touch events to the Librem5 to wake it up. At least it should wake up the Librem5 when the power-on is pressed on the NexDock. Right now, one needs to wake up both devices manually (with some wait until they have paired) until one can finally log in again.

@ChriChri, if i remember correctly, these were my findings during the test. If you want, we can write them down in a more reproducible way, check if we can find a work-around and try to sort the remainder apart for Purism and NexDock. Purism will rework the power management anyway to cope with suspend and your suggestion sounds reasonable. I think the internal screen should be switched off (per config), when docked, and the NexDock screen when the Librem5 normally blanks the screen. From NexDock side, a less alerting behavior should be configurable. And it should forward power to the Librem5 in any case, i think. And wake up the Librem5, when it is itself woken up (perhaps this has to be added from Purisms side, too).

In some parts, it is not clear to me how the devices would trigger each other in these cases. But i think, this can be worked out.


Good writing that covers the problem in a overall way.

I gotta catchup first to be able to use my l5 as daily driver, but then will gladly start contributing to the write-up and to some experiments how to solve the different issues discovered.

I now have a Nexdock 360 and can confirm the initial impressions of the OP. I am a little on the lazy side to dig through the steps to get the touch screen to be more reliable. Other than the sound not working everything else is really responsive! Now I can be a little more mobile with having a keyboard instead of relying only on my desktop dock.

1 Like

I am a little on the lazy side to dig through the steps to get the touch screen to be more reliable.

phosh-mobile-settings sets up the touch screen with a single click in the convergence tab:


Thanks for the heads up!

I installed phosh-mobile-settings but it doesn’t show a convergence tab. I restarted and even made sure the Nexdock was plugged in while power cycling so it detected convergence on boot, but still no convergence tab.

Any additional instructions I am missing? Even if that is to reach out to support :sweat_smile:

Additional instructions: Always report the version you installed :wink: and from where.

1 Like

Okay. It’s phosh-mobile-settings version 0.0.1 from PureOS Byzantium repos

I had ran simple ‘sudo apt install phosh-mobile-settings’ and that’s what installed

1 Like

You want apt update before that. You need 0.20.0:

1 Like

I did ‘apt update’ and tried ‘apt upgrade phosh-mobile-settings’ but it said I had the latest version at 0.0.1. I purged the package, updated repo again and installed phosh-mobile-settings but it again installed 0.0.1.

1 Like
$ apt policy phosh-mobile-settings
  Installed: 0.20.0-1pureos1
  Candidate: 0.20.0-1pureos1
  Version table:
 *** 0.20.0-1pureos1 500
        500 byzantium/main arm64 Packages
         99 landing/main arm64 Packages
        100 /var/lib/dpkg/status
1 Like

Next two/three ones would be:
sudo apt upgrade

Above one (sudo apt upgrade) should contain: sudo apt upgrade tzdata
Skip this one if below already works for you: sudo dpkg-reconfigure tzdata (Enter key will work there).

sudo apt install phosh-mobile-settings
apt list phosh-mobile-settings

Just noticed this one:

sudo apt upgrade phosh-mobile-settings

This is the output I get for ‘apt policy phosh-mobile-settings’ after I did ‘sudo apt update’ again.

$ apt policy phosh-mobile-settings
Installed: 0.0.1-0pureos1
Candidate: 0.0.1-0pureos1
Version table:
*** 0.0.1-0pureos1 500
500 byzantium/main arm64 Packages
100 /var/lib/dpkg/status

Thank you for your advice. After I upgraded ‘tzdata’ I tried ‘apt update’ and ‘apt upgrade phosh-mobile-settings’ but it seems to be stuck on that older version. Whatever repos I have enabled seem to only have the old version. I have whatever the default repos are, I have not touched them.

1 Like

I’m also on byzantium, but have never had it insalled. So figured I’d try it out. I wasn’t able to install it though. Also looks like it’s trying to install 0.0.1-0

purism@pureos:~$ sudo apt install phosh-mobile-settings
[sudo] password for purism: 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  libadwaita-1-0 libgtk-4-1 libgtk-4-bin libgtk-4-common
Suggested packages:
  libgtk-4-media-gstreamer | libgtk-4-media-ffmpeg
The following NEW packages will be installed:
  libadwaita-1-0 libgtk-4-1 libgtk-4-bin libgtk-4-common phosh-mobile-settings
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 29.5 kB/9123 kB of archives.
After this operation, 45.1 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
Err:1 byzantium/main arm64 phosh-mobile-settings arm64 0.0.1-0pureos1
  404  Not Found [IP: 443]
E: Failed to fetch  404  Not Found [IP: 443]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Thanks for your feedback and dialog! Now I see it is not directly about tzdata (it was just there, available as of today, as upgrade) therefore went back to show you this screenshot:

And as related to this post, @libwood should note this as well:

please make sure that you run:
sudo apt update
sudo apt upgradeYes
sudo apt autoremove
apt list systemd-timesyncdas shown above
sudo apt install systemd-timesyncd
sudo reboot
sudo apt update
apt list phosh-mobile-settings
sudo apt upgrade phosh-mobile-settings

Hope this helps, if issue systemd-timesyncd package related, as I think/guess, and while PureOS repo looks fine to me.

I do sudo apt update&& sudo apt upgrade every few days to look for new goodies. :slight_smile:.

Wasn’t sure if I had systemd-timesyncd so I got excited, but looks like I have it:
systemd-timesyncd is already the newest version (247.3-7).

apt list phosh-mobile-settings gave me:
phosh-mobile-settings/byzantium 0.0.1-0pureos1 arm64

I flashed it 2021-10-07, but don’t think I’ve ever changed any sources.

1 Like

How about executing sudo systemctl reboot and trying again … as above, please.

EDIT: @libwood, precise time related as well (should help there):

You mentioned mobile data. So I popped in my sim card, turned off wifi and made sure data was working.

Installing ntpdate went fine and no problem running ntpdate-debian:
19 Aug 15:51:09 ntpdate[2370]: adjust time server offset +0.003499 sec

app list results: (update and upgrade had nothing new)
systemd-timesyncd/byzantium,now 247.3-7 arm64 [installed]
phosh-mobile-settings/byzantium 0.0.1-0pureos1 arm64

Thought hey, maybe something up with cache. Ran sudo apt-get clean, then update and upgrade, but still no luck…

1 Like

Sorry (not sure how to help), but you can still run (after related download):
cd Download_Folder
sudo dpkg -i phosh-mobile-settings_0.20.0-1pureos1_arm64.deb
sudo apt-mark auto phosh-mobile-settings

1 Like

No worries. I appreciate it. Always thankful to have someone to engage with :smiley:

1 Like