Install balena etcher on PureOS

I tried to install Balena Etcher on PureOS to flash an SDcard with UmbrelOS (for a Rasberry Pi),

but I get this in the terminal:

It looks like we don’t currently support your distribution release and

: version. This is something that we can fix by adding it to our list of
: supported versions (see contact us below), or you can manually override
: the values below to an equivalent distribution that we do support:
: … distro=pureos version=10.0 codename=byzantium arch=x86_64

How do I do this manually? I have no experience with overriding.


How did you install it? there is an appimage that should run straight away.

Anyways to write an operating system in the sd you can use the dd command.

sudo dd if=/your/user/UmbrelOS.img of=/dev/mmcblkX

Replace mmcblkX by your sd, you can see it with the Disks app

or just use Gnome Disks to write/restore the image – that’s the best and easiest way IMO


I downloaded from the etcher website. it’s a zipfile. I see the appimage in my files, but when I click on ‘run’ nothing happens.

In properties --> permission I set ‘allow executing file as program’
Still doesn’t run… owner is ME.

Solved! removed it, downloaded it again, extracted and now it does run…
No idea what went wrong :slight_smile:

Multiwriter does the job for me.

The extracted balena etcher appimage file will not run. I’ve removed it, re-downloaded, and extracted multiple times and I’m still not able to start the application.

Any advice greatly appreciated.

Run it from the terminal and see what it says.

bradmills@PureDesk:~/Downloads$ chmod +x balenaEtcher-1.7.3-x64.AppImage
bradmills@PureDesk:~/Downloads$ ./balenaEtcher-1.7.3-x64.AppImage
Here is the error that was returned after attempting to execute the file from the terminal

“[3419:0204/] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I’m aborting now. You need to make sure that /tmp/.mount_balenaWn9W97/chrome-sandbox is owned by root and has mode 4755.
/tmp/.mount_balenaWn9W97/balena-etcher-electron: line 10: 3419 Trace/breakpoint trap “${script_dir}”/balena-etcher-electron.bin “$@”

Looks like a policy kit issue, same thing seems to happen on Debian.

TL;DR - You can try with sudo or append --no-sandbox to your terminal command.

1 Like