Install Unifi Controller to Librem Mini

Hello!

I wanted to install the unifi controller, but there is some problem with mongodb:

"user@user:~$ sudo apt-get update; sudo apt-get install unifi -y
Hit:1 https://…pureos amber InRelease
Get:2 https://…pureos amber-security InRelease [5.518 B]
Get:3 https://…pureos amber-updates InRelease [5.516 B]
Get:4 http://dl.ubnt.com/unifi/debian stable InRelease [3.024 B]
Get:5 http://dl.ubnt.com/unifi/debian stable/ubiquiti amd64 Packages [711 B]
Fetched 14,8 kB in 1s (13,6 kB/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
unifi : Depends: mongodb-server (>= 2.4.10) but it is not installable or
mongodb-10gen (>= 2.4.14) but it is not installable or
mongodb-org-server (>= 2.6.0) but it is not installable
Depends: mongodb-server (< 1:4.0.0) but it is not installable or
mongodb-10gen (< 4.0.0) but it is not installable or
mongodb-org-server (< 4.0.0) but it is not installable
E: Unable to correct problems, you have held broken packages.
user@user:~$ "

Sorry for not pasting the repos links here, but new users can paste only 2 links max.

Does anyone can find the same situation?

@gyari Welcome in the Purism forum!

Can you please give a little bit more background about unifi and your setup so that it is easier for us to help you? THX :slight_smile:

Eg.

  • which OS you use (+ version)
  • what unifi is
  • a link to unify and the repo you are using (eg. by using words or spaces instead of the direct link if you are not allowed to post more than 2 links)

It looks like the repos which hold the unmet dependencies you need are not present on your system.

You will need to add a repo that has the packages you want.

My advice? Install Ubuntu on that thing and install unifi. No more problems.

PureOS is a FOSS OS that does not make any compromises, which is great, if you are fully prepared to deal with that.

Ubuntu is the more practical approach.

Try this link, which addresses adding mongodb’s repo to Ubuntu (should also work for you)

Thanks for your replies!

It was tried on the latest (last week) Pure OS 9.0

This is what i have made so far:

  1. Added unifi repository (stable debian)

echo 'deb http://www.ui.com/downloads/unifi/debian stable ubiquiti' | sudo tee /etc/apt/sources.list.d/100-ubnt-unifi.list

  1. Autheticated the software

sudo wget -O /etc/apt/trusted.gpg.d/unifi-repo.gpg https://dl.ubnt.com/unifi/unifi-repo.gpg

  1. Than i tried to install the unifi software itself

sudo apt update; sudo apt install unifi -y

After this command i got the error about mongodb. Was there any mistake? I just wanted to try Pure OS with my programs.

You are using PureOS and are trying to install programs from Debian’s repos.
That creates the PureOS equivalent of a “FrankenDebian” ( https://wiki.debian.org/DontBreakDebian ).
In this case, the issue is simply a missing dependency. What can really cause problems is if
you install Debian components that conflict with PureOS components.

See the yellow box in the link I provided to help with the mongodb issue.

If you are still in need of a solution. Here how I manage to make it run on my Librem Mini running PureOS.

  1. Create a network bridge, with nmcli, on the host and connect it to the physical Ethernet interface of the librem mini.
  2. Configure KVM so that it knows the bridge exists
  3. Deploy a VM, with KVM, and install a debian 10 OS
  4. Ensure its network interface is attached to the created bridge
  5. Install the Unifi Network Controller on the VM
  6. Configure the NEtwork Controller and adopt any devices.

Here is my post on reddit when seeking for help configuring the bridge.

Hope this will help.