Installing Debian On A Librem 14

I’m more tech-savvy than some, but definitely nothing special by any means. I’m making this post to share my experience with trying to achieve my goal of installing Debian 10 kde on a new Librem 14 (I don’t like gnome), in hopes to help save others some time if they want to go the Debian kde route–and in hopes that someone can answer my unanswered questions. The Librem 14 I am working with has a 2TB NVME, and coreboot. Here are some of the things I discovered:

  1. I wasn’t able to install Debian 10 using the DVD iso. Every time I installed it and got to the end to reboot it, it would freeze at loading ramdisk. (Also, the mousepad doesn’t work during the install)

I did some research and came across a post here on Purism about a guy who couldn’t get pureos 9 to install on his Librem 14. Another user mentioned that the kernel in Pureos 9 was too old, and you needed a newer kernel which was in Pureos 10. Pureos9 is based on Debian 10, so I figured maybe that was related to my issues.

I then tried Debian 11 (bullseye) and was able to succeed installing it (eventually).

  1. Encrypting the entire disk using the “Guided - use entire disk and set up encrypted LVM” option on a 2TB NVME doesn’t work with Debian 11 (or 10). Something goes wrong with grub. I don’t know exactly what or why. It has something to do with grub needing to be accessible on a non-encrypted drive? Idk exactly.

Anyway, I found out that using the debian 11 live iso worked easiest regarding all the paritioning stuff. I used calabres and simply set up a swap partition and a / partition (encrypted nothing), and–all was well and worked!

But, I really wanted to encrypt the disk, so i figured I’d try to see if I could find a way to do it. So I repeated the install by making a swap partition, and then another partition for the rest. I even followed the pureos guidelines to make an unformatted 1Mib partition and selected the grub flag. But the install didn’t work; t grub couldn’t install. I then retried creating a separate unencrypted /boot partition trying to install the bootloader in there, but this didn’t work either. The only way I could encrypt anything was by encrypting just the /home partition. I left the / partition for the OS unencrypted and chose to install the bootloader there.

Does anyone have any advice on how I can encrypt the whole disk and solving the grub problem? Anything I came across suggested grub and NVME don’t mix and match well, but I don’t really understand how or why or how to fix it. Any advice would be appreciated.

  1. I added the pureos repos to my apt/sources.list. For anyone who wants them they are:
    deb byzantium main
    deb byzantium-updates main

But, they won’t work if you simply add the above because they aren’t signed. I couldn’t figure out how to add the keys, so i had to put [trusted=yes] after deb to get debian to trust the source.

I don’t know if it’s helpful to have added them. I thought it would be. Is it? If not, should I remove them?

Where can I find the keys to make them a trusted source?

  1. I noticed that when the laptop was plugged in, it wasn’t actually charging. I became nervous and thought something was wrong. But upon further research, I found out it was only supposed to charge when it hit below a certain threshold. Nicole made a post on that. BUT…

There was some kind of bug in that code so a new version has to be downloaded, otherwise it won’t charge right. Details here: https:// source. puri. sm/nicole.faerber/librem-ec-acpi-dkms/-/wikis/home

To install it, I did sudo apt-get install librem-ec-acpi-dkms and that worked–but I had to reboot the PC first for the changes to be there. Then I could adjust the charge_control_end_threshold and charge_control_start_threshold.

I’ll update this post with anything else noteworthy. I hope someone out there finds this helpful!

1 Like

You can download pureos-archive-keyring and do sudo dpkg -i for this particular package under related folder.

EDIT: Just thinking that your best install choices (current Debian 11 ones) were: debian-live-blsy-DI-rc2-amd64-kde.iso or perhaps preferable would be usage of debian-bullseye-DI-rc2-amd64-DVD-1.iso, with finishing Debian Installer process without installing Gnome (by skipping this step), as hopefully offers encryption within (I don’t recall now), and as it might be worth to be executed on L14 (just thinking loudly, not recommending anything). Afterwards (after first reboot) by using tasksel command should be (it is) easy to add KDE environment/packages.